3ccb835b28
Core Release v1.1.0 bat: don't link all binaries with fftw library, add missing header configure.ac: check for fftw3/m(sqrtf)/pthread only when BAT is enabled build: Do not try to detect cross-compiler BAT: Add Makefile and configures topology: Add command line topology tool to build topology binaries ALSA Control (alsactl) alsactl: Manage both save and restore in a single unit alsactl: Add path condition to alsa-store and alsa-restore services alsactl: terminate readlink result string Speaker Test speaker-test: fix option ordering speaker-test: Add option to specify signal scale alsa-info.sh alsa-info: Don't try update when wget isn't available alsatplg (topology) topology: Add command line topology tool to build topology binaries alsaucm alsaucm: Drop localbuild hacks amixer amixer: expand local storage for item name according to kernel code amixer: Don't set only the first item in sset_enum() aplay/arecord aplay: fix VU meter for S24_LE etc formats arecord: Remove only regular files aplay: Fix uninterruptible aplay aplay: Fix type for signal flag bat (basic audio tester) bat: add all headers to noinst_HEADERS bat: don't link all binaries with fftw library, add missing header BAT: Add missing locale.h header BAT: Add man page BAT: Use dynamic temp file BAT: Change comments and interface of usage() BAT: Use colon instead of comma for separation BAT: Remove redundant message strings BAT: Add Makefile and configures BAT: Add spectrum analysis functions BAT: Add converting functions BAT: Add signal generator BAT: Add playback and record functions BAT: Add common definitions and functions BAT: Add initial functions
32 lines
748 B
C
32 lines
748 B
C
$NetBSD: patch-alsaloop_alsaloop.c,v 1.3 2016/02/18 15:16:33 wiz Exp $
|
|
|
|
--- alsaloop/alsaloop.c.orig 2015-10-27 16:34:26.000000000 +0000
|
|
+++ alsaloop/alsaloop.c
|
|
@@ -24,6 +24,16 @@
|
|
#include <stdlib.h>
|
|
#include <string.h>
|
|
#include <sched.h>
|
|
+/* For ERESTART */
|
|
+#if defined(__NetBSD__)
|
|
+#include <sys/param.h>
|
|
+/* NetBSD 6 does not have _KMEMUSER. And _KERNEL breaks build of alsa-utils. */
|
|
+#if __NetBSD_Version__ < 699000000
|
|
+#define ERESTART -3
|
|
+#else
|
|
+#define _KMEMUSER 1
|
|
+#endif
|
|
+#endif
|
|
#include <errno.h>
|
|
#include <getopt.h>
|
|
#include <alsa/asoundlib.h>
|
|
@@ -34,6 +44,10 @@
|
|
#include <signal.h>
|
|
#include "alsaloop.h"
|
|
|
|
+#if !defined(ESTRPIPE)
|
|
+#define ESTRPIPE EPIPE
|
|
+#endif
|
|
+
|
|
struct loopback_thread {
|
|
int threaded;
|
|
pthread_t thread;
|