This large commit accomplishes the following: 1) Switch USE_LANGUAGES=ada to require lang/gcc5-aux (gcc 5.4) instead of lang/gcc-aux (gcc 4.9.2) on gcc.mk 2) Bump affected ports and fix paths as necessary 3) Upgrade devel/gprbuild to the latest release - No longer requires lang/gnat_util - gprslave requires gcc6-aux, so it was disabled for now 4) Fix lang/gnat_util but set PKG_SKIP_REASON - It has no further purpose in the pkgsrc tree - It has no practical purpose outside of the pkgsrc tree - Indicate intent to remove from tree in Jan. 2017 5) Set devel/GPS as failed with PKG_FAIL_REASON - This version of GPS is several years old and at the time they were strongly tied to compiler. - Latest release of GPS require gcc6-aux (not available) and several new and complex dependencies - maintainer (me) has no interest to continue supporting it - Leaving GPS in place until Jan 2017 to give another person chance to upgrade and take over support - Latest version in FreeBSD Ports Collection as a reference point
28 lines
1.3 KiB
XML
28 lines
1.3 KiB
XML
$NetBSD: patch-share_gprconfig_compilers.xml,v 1.3 2016/11/25 20:36:49 marino Exp $
|
|
|
|
Tailor standard gprbuild to recognize gcc-aux / Ada framework
|
|
|
|
--- share/gprconfig/compilers.xml.orig 2015-04-28 15:02:41 UTC
|
|
+++ share/gprconfig/compilers.xml
|
|
@@ -693,17 +693,15 @@
|
|
</version>
|
|
<languages>Ada</languages>
|
|
<variable name="gcc_version">
|
|
- <external>${PREFIX}gcc -v</external>
|
|
+ <external>${PREFIX}ada -v</external>
|
|
<grep regexp="^[-\w]*gcc \S+ (\S+)" group="1"></grep>
|
|
</variable>
|
|
<runtimes default="default,kernel,native">
|
|
- <directory group="default" >\.\./lib/gcc(-lib)?/$TARGET/$gcc_version/adalib/</directory>
|
|
- <directory group="default" contents="^rts-">\.\./lib/gcc(-lib)?/$TARGET/$gcc_version/ada_object_path</directory>
|
|
- <directory group="2" >\.\./lib/gcc(-lib)?/$TARGET/$gcc_version/rts-(.*)/adalib/</directory>
|
|
- <directory group="1" >\.\./$TARGET/lib/gnat/(.*)/adalib/</directory>
|
|
+ <directory group="default">\.\./lib/gcc/$TARGET/$gcc_version/adalib</directory>
|
|
+ <directory group="0">/usr/local/gcc5-aux/lib/gcc/$TARGET/$gcc_version/adalib</directory>
|
|
</runtimes>
|
|
<target>
|
|
- <external>${PREFIX}gcc -dumpmachine</external>
|
|
+ <external>${PREFIX}ada -dumpmachine</external>
|
|
<grep regexp="[^\r\n]+"></grep>
|
|
</target>
|
|
</compiler_description>
|