pkgsrc/lang/gcc47/patches/patch-libiberty_Makefile.in
jperkin 9ec65c7380 Backport dsainty's gcc48 fix to gcc47.
The ${PREFIX}/include/ansidecl.h installed by devel/binutils is not
necessarily compatible (E.g. binutils-2.25 does not define PARAMS).  Adjust
the include path priority so the internal ansidecl.h gets precedence, allowing
cp-demangle.c to use libiberty.h without compilation errors.
2015-06-19 09:05:11 +00:00

18 lines
847 B
Text

$NetBSD: patch-libiberty_Makefile.in,v 1.1 2015/06/19 09:05:11 jperkin Exp $
The ${PREFIX}/include/ansidecl.h installed by devel/binutils is not
necessarily compatible (E.g. binutils-2.25 does not define PARAMS). Adjust
the include path priority so the internal ansidecl.h gets precedence, allowing
cp-demangle.c to use libiberty.h without compilation errors.
--- libiberty/Makefile.in.orig 2012-08-06 14:34:27.000000000 +0000
+++ libiberty/Makefile.in
@@ -112,7 +112,7 @@ installcheck: installcheck-subdir
INCDIR=$(srcdir)/$(MULTISRCTOP)../include
-COMPILE.c = $(CC) -c @DEFS@ $(CFLAGS) $(CPPFLAGS) -I. -I$(INCDIR) $(HDEFINES) @ac_libiberty_warn_cflags@
+COMPILE.c = $(CC) -c @DEFS@ -I. -I$(INCDIR) $(CFLAGS) $(CPPFLAGS) $(HDEFINES) @ac_libiberty_warn_cflags@
# Just to make sure we don't use a built-in rule with VPATH
.c.$(objext):