pkgsrc/databases/openldap/patches/patch-aa
simonb c2479e4f47 Work around ELF bug with libwrap in a similar way to the ucd-snmp
package (pointed out by David Brownlee).  We also need to remove -lwrap
from the tools directory libraries - hence the post-configure target to
make sure SLAPD_LIBS is empty in servers/slapd/tools/Makefile.
1999-09-17 06:46:31 +00:00

39 lines
1,020 B
Text

$NetBSD: patch-aa,v 1.3 1999/09/17 06:46:32 simonb Exp $
--- configure.orig Thu Aug 26 04:39:37 1999
+++ configure Wed Sep 15 11:47:45 1999
@@ -2318,6 +2318,7 @@
# Save cache, so that ltconfig can load it
+if false; then
# Actually configure libtool. ac_aux_dir is where install-sh is found.
CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
@@ -2336,6 +2337,8 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+fi
+
# Redirect the config.log output again, so that the ltconfig log is not
# clobbered by the next message.
exec 5>>./config.log
@@ -7064,6 +7067,7 @@
if test $ac_cv_header_tcpd_h != yes ; then
have_wrappers=no
else
+if false; then
echo $ac_n "checking for main in -lwrap""... $ac_c" 1>&6
echo "configure:7069: checking for main in -lwrap" >&5
ac_lib_var=`echo wrap'_'main | sed 'y%./+-:%__p__%'`
@@ -7099,6 +7103,9 @@
else
echo "$ac_t""no" 1>&6
have_wrappers=no
+fi
+else
+ have_wrappers=yes
fi
fi