pkgsrc/cad/klayout/patches/patch-src_Makefile.rules
mef 8cec462d02 Updated cad/klayout to 0.24.9
-----------------------------
From: http://klayout.de/development.html
Release date: 2016-11-29
 Enhancements: The RBA::Region#smooth function was enhanced to give
 	       somewhat better results
 Enhancements: DXF's circle approximation can now also specified
 	       through an "accuracy" parameter: if less than the number of specified
	       points is required to achieve the given accuracy, the number is
	       reduced accordingly. This also applies to the polygon interpolation
	        of spline and arc curves.

 Enhancement: RBA integration now is compatible with Ruby 2.3 which
	      allows building on Ubuntu 16 as well.
 Enhancement: OASIS files with instance angles >360 were rejected
 	       before. Now, this has turned into a warning.

 Bugfix: DEF reader was failing to read MASK/via combinations.
 Bugfix: The marker browser's "show only rules with errors" option was
	 enabled again on sorting of errors.
 Bugfix: DRC: Using Layout objects for inputs didn't work
 Bugfix: Copying Hierarchy treets containing PCell's made the PCell's
 	  being turned into static cells.
2017-01-01 09:15:00 +00:00

21 lines
669 B
Text

$NetBSD: patch-src_Makefile.rules,v 1.2 2017/01/01 09:15:00 mef Exp $
date: 2016-11-21 07:14:47 +0900; author: joerg;
Restrict a few very memory hungry files to -O1.
--- src/Makefile.rules.orig 2016-11-20 01:03:39.000000000 +0000
+++ src/Makefile.rules
@@ -165,6 +165,13 @@ vpath %.ui $(SOURCE)
%.o: %.cc %.d
$(CXX) $(INC) $(CXXOPTS_PROD) $@ $(<)
+gsiExpression.o: gsiExpression.cc gsiExpression.d
+ $(CXX) $(INC) $(CXXOPTS_PROD) $@ $(<) -O1
+pyaMarshal.o: pyaMarshal.cc pyaMarshal.d
+ $(CXX) $(INC) $(CXXOPTS_PROD) $@ $(<) -O1
+rba.o: rba.cc rba.d
+ $(CXX) $(INC) $(CXXOPTS_PROD) $@ $(<) -O1
+
%_moc.o: %_moc.cc %.dm
$(CXX) $(INC) $(CXXOPTS_PROD) $@ $(<)