acc0a12614
Add php80 package version 8.0.3 (PHP 8.0.3) with current PHP framework of pkgsrc. PHP is a widely-used open source general-purpose scripting language that is especially suited for web development and can be embedded into HTML. It is modular, and object-oriented. Much of its syntax is borrowed from C, Java and Perl with a couple of unique PHP-specific features thrown in. The language is designed to allow web developers to write dynamically generated pages quickly. PHP 8.0 comes with numerous improvements and new features such as * Union Types * Named Arguments * Match Expressions * Attributes * Constructor Property Promotion * Nullsafe Operator * Weak Maps * Just In Time Compilation * And much much more...
19 lines
677 B
JavaScript
19 lines
677 B
JavaScript
$NetBSD: patch-sapi_cli_Makefile.frag,v 1.1 2021/03/07 13:41:36 taca Exp $
|
|
|
|
Needed on NetBSD with PaX MPROTEXT, otherwise core dump with:
|
|
#1 0x00000000004d0d87 in _pcre_jit_exec ()
|
|
#2 0x00000000004a53f1 in php_pcre_exec ()
|
|
https://bugs.php.net/bug.php?id=72281
|
|
|
|
--- sapi/cli/Makefile.frag.orig 2016-04-28 18:12:27.000000000 +0000
|
|
+++ sapi/cli/Makefile.frag
|
|
@@ -2,6 +2,9 @@ cli: $(SAPI_CLI_PATH)
|
|
|
|
$(SAPI_CLI_PATH): $(PHP_GLOBAL_OBJS) $(PHP_BINARY_OBJS) $(PHP_CLI_OBJS)
|
|
$(BUILD_CLI)
|
|
+ @if test -x /usr/sbin/paxctl; then \
|
|
+ /usr/sbin/paxctl +m $(SAPI_CLI_PATH); \
|
|
+ fi
|
|
|
|
install-cli: $(SAPI_CLI_PATH)
|
|
@echo "Installing PHP CLI binary: $(INSTALL_ROOT)$(bindir)/"
|