pkgsrc/games/powermanga/patches/patch-ad
salo 127337db81 Updated to version 0.79
- obey VARBASE
- support SETGIDGAME installations, simplify patch-ad

Changes:

- fixes some minor bugs and memory leaks (Patrice Duhamel and Jozef Behran)
- duplicates the set of cursor movement keys on the numeric keypad (modus)
- disables the F key (full screen) while inputting a player name
2005-01-30 23:48:32 +00:00

42 lines
1.5 KiB
Text

$NetBSD: patch-ad,v 1.2 2005/01/30 23:48:32 salo Exp $
--- src/Makefile.in.orig 2004-08-01 22:37:57.000000000 +0200
+++ src/Makefile.in 2005-01-30 21:45:13.000000000 +0100
@@ -133,8 +133,8 @@
target_vendor = @target_vendor@
NULL =
-gamesdir = $(prefix)/games
-scoredir = /var/games
+gamesdir = $(prefix)/bin
+scoredir = $(localstatedir)/games
score = powermanga.hi
games_PROGRAMS = powermanga
@@ -321,7 +321,7 @@
$(AUTOMAKE) --gnu src/Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
-gamesPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+gamesPROGRAMS_INSTALL = $(BSD_INSTALL_GAME)
install-gamesPROGRAMS: $(games_PROGRAMS)
@$(NORMAL_INSTALL)
$(mkinstalldirs) $(DESTDIR)$(gamesdir)
@@ -1505,13 +1505,10 @@
install-data-hook:
- -chown root:games "$(DESTDIR)/$(gamesdir)/powermanga"
- -chmod 2755 "$(DESTDIR)/$(gamesdir)/powermanga"
- $(INSTALL) -d $(DESTDIR)/$(scoredir)
- -for suffix in "-easy" "" "-hard"; do \
- touch "$(DESTDIR)/$(scoredir)/$(score)$$suffix"; \
- chown root:games "$(DESTDIR)/$(scoredir)/$(score)$$suffix"; \
- chmod 644 "$(DESTDIR)/$(scoredir)/$(score)$$suffix"; \
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)/$(scoredir)
+ @for suffix in "-easy" "" "-hard"; do \
+ $(TOUCH) "$(WRKSRC)/$(score)$$suffix" && \
+ $(BSD_INSTALL_GAME_DATA) "$(WRKSRC)/$(score)$$suffix" $(DESTDIR)/$(scoredir)/; \
done
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.