11a4af3693
to accomplish the same thing. * Move the arm compiler hack into a hacks.mk file.
62 lines
2 KiB
Text
62 lines
2 KiB
Text
$NetBSD: patch-ac,v 1.2 2006/03/31 17:11:54 jlam Exp $
|
|
|
|
--- configure.orig 2001-04-26 10:44:54.000000000 -0400
|
|
+++ configure
|
|
@@ -1957,6 +1957,9 @@ if test "${with_curses_driver+set}" = se
|
|
|
|
fi
|
|
|
|
+test "x$SLANG_PREFIX" != x || SLANG_PREFIX=/usr/local
|
|
+test "x$NCURSES_PREFIX" != x || NCURSES_PREFIX=/usr/local
|
|
+
|
|
# Check whether --with-gpm-mouse or --without-gpm-mouse was given.
|
|
if test "${with_gpm_mouse+set}" = set; then
|
|
withval="$with_gpm_mouse"
|
|
@@ -3145,7 +3148,7 @@ EOF
|
|
|
|
if $search_slang
|
|
then
|
|
- if test -f /usr/local/include/slang.h
|
|
+ if test -f $SLANG_PREFIX/include/slang.h
|
|
then
|
|
LIBS1="$LIBS"
|
|
LIBS="$LIBS "
|
|
@@ -3197,10 +3200,10 @@ else
|
|
fi
|
|
|
|
if test "x$ac_cv_lib_slang_SLsmg_init_smg" = xyes; then
|
|
- echo "$ac_t""Found slang on /usr/local/include/slang.h" 1>&6
|
|
+ echo "$ac_t""Found slang on $SLANG_PREFIX/include/slang.h" 1>&6
|
|
AALIB_LIBS="$AALIB_LIBS -lslang"
|
|
LIBS="$LIBS "
|
|
- CFLAGS="$CFLAGS -I/usr/local/include/slang "
|
|
+ CFLAGS="$CFLAGS -I$SLANG_PREFIX/include/slang "
|
|
slang_driver=true
|
|
search_slang=false
|
|
cat >> confdefs.h <<\EOF
|
|
@@ -3453,7 +3456,7 @@ EOF
|
|
|
|
if $search_ncurses
|
|
then
|
|
- if test -f /usr/local/include/ncurses.h
|
|
+ if test -f NCURSES_PREFIX/include/ncurses.h
|
|
then
|
|
LIBS1="$LIBS"
|
|
LIBS="$LIBS "
|
|
@@ -3505,13 +3508,13 @@ else
|
|
fi
|
|
|
|
if test "x$ac_cv_lib_ncurses_initscr" = xyes; then
|
|
- echo "$ac_t""Found ncurses on /usr/local/include/ncurses.h" 1>&6
|
|
+ echo "$ac_t""Found ncurses on NCURSES_PREFIX/include/ncurses.h" 1>&6
|
|
AALIB_LIBS="$AALIB_LIBS -lncurses"
|
|
LIBS="$LIBS "
|
|
- CFLAGS="$CFLAGS -L/usr/local/lib"
|
|
+ CFLAGS="$CFLAGS -LNCURSES_PREFIX/lib"
|
|
search_ncurses=false
|
|
curses_driver=true
|
|
- screen_manager=-I/usr/local/include
|
|
+ screen_manager=-INCURSES_PREFIX/include
|
|
cat >> confdefs.h <<\EOF
|
|
#define USE_NCURSES 1
|
|
EOF
|