2d6db54b4d
- Link with the C++ compiler because this is written in C++. - Link with all the required libraries to prevent undefined symbols. - Add only libtool libraries to LT_LIBS. Based on patches provided by Ben Collver in PR 34495.
13 lines
459 B
Text
13 lines
459 B
Text
$NetBSD: patch-ad,v 1.5 2006/12/10 23:02:40 minskim Exp $
|
|
|
|
--- style/Makefile.sub.orig 2002-11-15 14:46:50.000000000 -0800
|
|
+++ style/Makefile.sub
|
|
@@ -1,6 +1,7 @@
|
|
LTVERSION=0:1:0
|
|
LIB=ostyle
|
|
-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
|
|
+DEPLIBS=$(TOP)/grove/libogrove.la $(TOP)/spgrove/libospgrove.la \
|
|
+ -lm -losp -L$(TOP)/grove -L$(TOP)/grove/.libs \
|
|
-L$(TOP)/lib -L$(TOP)/lib/.libs \
|
|
-L$(TOP)/spgrove -L$(TOP)/spgrove/.libs
|
|
OBJS=LangObj.o \
|