ea74fdb7e4
Changelog: Based on xulrunner 41.0 Security fixes: 2015-114 Information disclosure via the High Resolution Time API 2015-113 Memory safety errors in libGLES in the ANGLE graphics library 2015-112 Vulnerabilities found through code inspection 2015-111 Errors in the handling of CORS preflight request headers 2015-110 Dragging and dropping images exposes final URL after redirects 2015-109 JavaScript immutable property enforcement can be bypassed 2015-108 Scripted proxies can access inner window 2015-107 Out-of-bounds read during 2D canvas display on Linux 16-bit color depth systems 2015-106 Use-after-free while manipulating HTML media content 2015-105 Buffer overflow while decoding WebM video 2015-104 Use-after-free with shared workers and IndexedDB 2015-103 URL spoofing in reader mode 2015-102 Crash when using debugger with SavedStacks in JavaScript 2015-101 Buffer overflow in libvpx while parsing vp9 format video 2015-100 Arbitrary file manipulation by local user through Mozilla updater 2015-99 Site attribute spoofing on Android by pasting URL with unknown scheme 2015-98 Out of bounds read in QCMS library with ICC V4 profile attributes 2015-97 Memory leak in mozTCPSocket to servers 2015-96 Miscellaneous memory safety hazards (rv:41.0 / rv:38.3)
43 lines
1.3 KiB
Text
43 lines
1.3 KiB
Text
$NetBSD: patch-as,v 1.22 2015/10/02 22:49:36 ryoon Exp $
|
|
|
|
* Fix _res is not supported for multi-threaded programs. error.
|
|
* Treat DragonFly like FreeBSD.
|
|
|
|
--- mozilla/js/src/configure.in.orig 2015-09-25 07:35:29.000000000 +0000
|
|
+++ mozilla/js/src/configure.in
|
|
@@ -2190,8 +2190,7 @@ AC_LANG_CPLUSPLUS
|
|
|
|
MOZ_CXX11
|
|
|
|
-dnl Check for .hidden assembler directive and visibility attribute.
|
|
-dnl Borrowed from glibc configure.in
|
|
+dnl Setup default hidden visibility and wrapped system headers.
|
|
dnl ===============================================================
|
|
if test "$GNU_CC" -a "$OS_TARGET" != WINNT; then
|
|
AC_DEFINE(HAVE_VISIBILITY_HIDDEN_ATTRIBUTE)
|
|
@@ -3029,7 +3028,7 @@ if test "$MOZ_MEMORY"; then
|
|
*-darwin*)
|
|
AC_DEFINE(MOZ_MEMORY_DARWIN)
|
|
;;
|
|
- *-*freebsd*)
|
|
+ *-*freebsd*|*-*dragonfly*)
|
|
AC_DEFINE(MOZ_MEMORY_BSD)
|
|
;;
|
|
*-android*|*-linuxandroid*)
|
|
@@ -3879,6 +3878,16 @@ MOZ_SUBCONFIGURE_ICU()
|
|
dnl ========================================================
|
|
dnl JavaScript shell
|
|
dnl ========================================================
|
|
+ICU_LIB_NAMES=
|
|
+MOZ_NATIVE_ICU=
|
|
+MOZ_ARG_WITH_BOOL(system-icu,
|
|
+[ --with-system-icu
|
|
+ Use system icu (located with pkgconfig)],
|
|
+ MOZ_NATIVE_ICU=1)
|
|
+
|
|
+if test -n "$MOZ_NATIVE_ICU"; then
|
|
+ PKG_CHECK_MODULES(MOZ_ICU, icu-i18n >= 50.1)
|
|
+fi
|
|
|
|
MOZ_CHECK_ALLOCATOR
|
|
|