9ac576643f
Patch provided by Onno van der Linden via pkg/50803. Changes: 2.5.0 - "Consolidation" * Autotools and packaging changes: - Upgraded autoconf version requirement to 2.60 - Added '--with-alsa' to suppress ALSA sound driver inclusion - Added '--without-oss' to suppress OSS sound driver inclusion - Added '--disable-cache' to remove tags cache support - Added specific GDB support to '--enable-debug' - Refactor decoder plug-ins' autoconf scripts into source directories - Ensure that all decoders get into the source distribution tarball - Removed SID decoder's dependance on .la-file presence - Removed distribution-specific .spec file - Minor reformatting of the configure summary - Added warnings for various deprecations and potential problems - Added warnings for unmet future package requirements - Updated GNU boilerplate text * Improved support for embedded systems: - Refined FFmpeg decoder configuration for use with cross-compilation - Provided use of Tremor with the Vorbis decoder - Improve portability to non-GNU library platforms - Added --with-libiconv-prefix configure option * Audio driver changes: - Allow use of the OSSv4 per-application mixer API - Provided SNDIO support for OpenBSD systems (Alexander Polakov) * New and changed audio decoders: - New TiMidity decoder for MIDI (Hendrik Iben) - Migrate AAC decoder to later FAAD2 API (Max Klinger) - Added AAC+ (HE-AAC) support to AAC decoder - New SidPlay2 decoder for SID (Hendrik Iben) - New Modplug decoder (Hendrik Iben) - New WavPack decoder (Alexandrov Sergey) - Renamed SndFile plugin for consistancy - Removed M4A format support from AAC decoder plugin - Removed WAV format support from ModPlug decoder plugin - Detect huge files in certain formats which SndFile cannot play - Improved (drastically in some cases) the accuracy of AAC durations * Overhauled FFmpeg/LibAV decoder: - Resolved FFmpeg API deprecations - Provided LibAV compatibility - Provided proper stereo downmixing - Provided locking support for non-thread-safe library functions - Provided better FFmpeg or LibAV discrimination - Provided better audio duration reliability determination - Increased number of decodable formats (including Xiph Opus) - Added decoding of audio from video formats - Added logging of FFmpeg/LibAV messages - Added seeking in most (but not all) formats - Added handling for "planar" codecs - Excluded experimental codecs from decoding - Fixed misreporting of tags, duration and bitrates - Fixed memory and file descriptor leakages - Fixed severe distortion on 8-bit samples - Fixed loop playing FLAC files - Fixed many FFmpeg/LibAV API breakages - Fixed many miscellaneous bugs - Detect over-length (and therefore broken) WAV files - Fixed log formatting when FFmpeg messages contain newline characters * Audio reproduction changes: - Improved support for 8-bit sample size - Added software mixer (Hendrik Iben) - Added parametric equalizer (Hendrik Iben) - Fixed many bugs which produced distorted sound - Fixed bugs in 24-bit sample handling (Tomasz Golinski) * General configuration file changes: - Reconciled and regularised example config and keymap files - Introduced lists and function-like syntax - Introduced variable substitution - Introduced symbol and boolean option types - Improved security of the configuration file - Automatic clearing of an overridden default key binding - Made processing of keymap file consistant with that of config file * Changed configuration file options: - Layout# options moved to a list and function-like syntax - SoundDriver option moved to a list syntax - Renamed OSSMixerChannel to OSSMixerChannel1 - Renamed ALSAMixer to ALSAMixer1 - QueueNextSongReturn moved to yes/no values - TagsCacheSize set to zero now disables tag caching * New configuration file options: - OnSongChange: run an external command (Jack Miller) - RepeatSongChange: govern the running of the OnSongChange command - OnStop: run an external command on stopping - EnforceTagsEncoding: substitutes ID3v1TagsEncoding for ISO-8859-1 encoding in ID3v2 tags (Aleks Sherikov) - FileNamesIconv: converts from local to UTF8 encoding for file names (Aleks Sherikov) - NonUTFXterm: converts UTF8 to local encoding for X-Term titles (Aleks Sherikov) - AutoLoadLyrics: says whether MOC should look for lyrics files - PreferredDecoders: allow finer control over decoder selection - XTerms: externalises terminals regarded as X-Terms - UseMIMEMagic: says whether to identify audio files by using MIME - JackStartServer: autostart JACK the server (Max Klinger) - ShowTimePercent: set the percent played state (Daniel T. Borelli) - Various options for SidPlay2, Modplug and TiMidity support * New command line options: - '-j' to jump to some position in the current track (Nuno Cardoso) - '-O' to override configuration file settings - '-Q' to display user formatted information (Juho Hämäläinen) - '-q' to queue files from command line (Martin Milata) - '-t' and '--on/off' to toggle or set playback options (Jack Miller) - '-v' to set the volume (Jack Miller) * Screen handling changes: - Changed minimum screen height to 7 lines (Tero Marttila) - Added support for GNU screen title (Jonathan Derque) - Restored screen to console mode after reporting fatal errors - Populated playlist panel when loading default playlist file - Removed default playlist autofocus at start - Fixed overlength highlight bar - Fixed screen upset when tags contain control characters - Fixed some screen upsets when tags contain UTF-8 characters (firejox) - Fixed screen upset caused by screen(1) mis-detection * New and updated client interaction features: - 'a' command: also add a directory to the playlist (Filippo Giunchedi) - 'L' command: display music lyrics (Géraud Le Falher) - 'Y' command: prune unreadable files from the playlist (tyranix) - Queued messages for display in the message area - Added play queue (Martin Milata) - Mark a fragment of a file which can be passed to external commands - Clear status message after a stream open failure - Minor help menu clarifications * Improve text entry history and editting: - Recognise ^u (by default) as delete to start of line - Recognise ^k (by default) as delete to end of line - Save and restore entered text prior to history scrolling - Save history entry modifications - Do not save adjacent duplicate entries - Do not save or modify with blank entries - Position cursor at end of restored or history line * Theme changes: - Enabled highlighted playlist numbers and file times (Marc Tschiesche) - Fixed miscoloured frame when switching themes (Alexander Polakov) - Fixed default colour settings - Fixed cursor placement in themes menu (Alex Merenstein) - Fixed ordering of theme files in themes menu - Fixed new attributes application on theme switching (Alex Merenstein) * General code cleaning: - Refactoring, optimisations and cosmetic improvements - Silenced many build warnings and errors - Replaced various deprecated, legacy and platform-specific functions - Improved thread safety * Significant bug fixes: - Fixed stale locks freeze in tags cache database following a crash - Fixed CURL timeout for internet streaming errors (Daniel Stenberg) - Fixed audio distortion on MP3 file having overly long tag values - Fixed false positive stream detection in the MP3 decoder - Fixed Ogg/Vorbis stream detection in the Vorbis decoder - Fixed 'LRINTF error' raised when reconfiguring MOC - Fixed backspace key mishandling - Fixed client interface meta-key handling - Fixed pthread stack overflow segfault on OpenBSD - Fixed segfault when text entry history becomes full - Fixed segfault processing playlists with relative paths - Fixed memory corruptions when toggling tag reading - Fixed assertion when a second client is started - Fixed slow memory leak in client on long-playing streams - Fixed severe distortion on 11025Hz 16-bit mono audios - Fixed freeze at end of playing audio file - Fixed server crash when attempting to play a deleted file - Fixed MIME type detection on HTTP redirection - Fixed crash when mixer value is above 100% - Fixed handling of huge (greater than 2 GiB) files - Fixed sub-second audio truncation on ALSA - Fixed segfault when MIME-detected MP3 file has no "extension" - Fixed segfault when using '--format' without an audio playing - Workaround for streams that have the actual title as tags/comments - Indentified cause of "undefined symbol" build errors - Plugged all known memory and file descriptor leaks - Fixed nonsense duration values returned on some corrupt FLAC files - Fixed 'time >= 0' assertion at change of audio file - Fixed client event notification failure in some circumstances - Fixed client abort on duplicated playlist filenames - Fixed delayed client exit when server invokes long-running scripts (Alex Merenstein) - Fixed occasional server freeze on logging when running scripts - Fixed non-conforming 'User-Agent' HTTP request header * Miscellaneous: - Updated and reformatted mocp manpage and equalizer README file - Made many warning and error reports more informative and consistant - Better logging of more problem determination information - More informative version information display - Introduced MD5-based decoder verification tools - Improved compatibility with 64-bit systems - Improved compatibility with big-endian systems - Moved tags cache to a Berkeley DB - Integration of down-stream distribution patches - Fixed frames to duration calculations in ALSA - Fixed some mutex management bugs - Fixed many bugs which crashed MOC
18 lines
574 B
Text
18 lines
574 B
Text
$NetBSD: patch-ab,v 1.3 2016/02/16 08:46:01 leot Exp $
|
|
|
|
Check for sched_get_priority_max being in -lrt.
|
|
|
|
--- configure.in.orig 2014-08-30 02:32:27.000000000 +0000
|
|
+++ configure.in
|
|
@@ -95,7 +95,10 @@ AC_CHECK_HEADERS([fcntl.h string.h strin
|
|
AC_MSG_ERROR([Can't find required header files.]))
|
|
AC_CHECK_HEADERS([sys/select.h byteswap.h])
|
|
|
|
-AC_CHECK_FUNCS([sched_get_priority_max])
|
|
+AC_CHECK_FUNCS([sched_get_priority_max], ,
|
|
+ [AC_CHECK_LIB([rt],
|
|
+ [sched_get_priority_max],
|
|
+ [EXTRA_LIBS="$EXTRA_LIBS -lrt"])])
|
|
|
|
dnl langinfo
|
|
AC_CHECK_HEADERS([langinfo.h])
|