buildlink2.mk files back into the main trunk. This provides sufficient buildlink2 infrastructure to start merging other packages from the buildlink2 branch that have already been converted to use the buildlink2 framework.
43 lines
1 KiB
Text
43 lines
1 KiB
Text
$NetBSD: patch-af,v 1.2 2002/08/25 18:39:46 jlam Exp $
|
|
|
|
--- configure.orig Wed Feb 17 23:58:33 1999
|
|
+++ configure Sun May 27 18:43:19 2001
|
|
@@ -78,6 +78,8 @@
|
|
ac_help="$ac_help
|
|
--with-gnu-ld assume the C compiler uses GNU ld [default=no]"
|
|
ac_help="$ac_help
|
|
+ --enable-tools Build VFlib tools"
|
|
+ac_help="$ac_help
|
|
--with-freetype[=LIB] Link FreeType library LIB [LIB=ttf]"
|
|
ac_help="$ac_help
|
|
--with-freetype-includedir=DIR FreeType include files are in DIR"
|
|
@@ -1480,6 +1614,14 @@
|
|
fi
|
|
|
|
|
|
+# Check whether --enable-tools or --disable-tools was given.
|
|
+if test "${enable_tools+set}" = set; then
|
|
+ enableval="$enable_tools"
|
|
+ build_tools=yes
|
|
+else
|
|
+ build_tools=no
|
|
+fi
|
|
+
|
|
|
|
|
|
|
|
@@ -2616,6 +2761,7 @@
|
|
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
|
|
|
|
|
|
+if test "$build_tools" = "yes" ; then
|
|
if test -d /usr/openwin ; then \
|
|
(cd tools; \
|
|
OPENWINHOME=/usr/openwin; \
|
|
@@ -2623,5 +2769,6 @@
|
|
xmkmf;) \
|
|
else \
|
|
(cd tools; xmkmf -a) \
|
|
+fi
|
|
fi
|
|
|