pkgsrc/devel/py-multiprocessing/patches/patch-aa
drochner 8b35460618 add py-multiprocessing-2.6.2.1, a threading package which was
integrated into the main Python distribution in 2.6
2010-11-02 19:20:16 +00:00

19 lines
570 B
Text

$NetBSD: patch-aa,v 1.1.1.1 2010/11/02 19:20:16 drochner Exp $
--- setup.py.orig 2009-07-30 12:36:48.000000000 +0000
+++ setup.py
@@ -65,6 +65,14 @@ elif sys.platform.startswith('openbsd'):
HAVE_FD_TRANSFER=1,
)
libraries = []
+elif sys.platform.startswith('netbsd'):
+ macros = dict(
+ HAVE_SEM_OPEN=1,
+ HAVE_SEM_TIMEDWAIT=0,
+ HAVE_FD_TRANSFER=1,
+ HAVE_BROKEN_SEM_GETVALUE=1
+ )
+ libraries = ['rt']
else: # Linux and other unices
macros = dict(
HAVE_SEM_OPEN=1,