pkgsrc/cross/avr-binutils/patches/patch-ag
mef 7a5de17974 Updated cross/avr-binutils 2.24 to 2.27
----------------------------------
(From binutils/NEWS)
----------------------------------
Changes in 2.27:

* Add a configure option, --enable-64-bit-archive, to force use of a
  64-bit format when creating an archive symbol index.

* Add --elf-stt-common= option to objcopy for ELF targets to control
  whether to convert common symbols to the STT_COMMON type.

Changes in 2.26:

* Add option to objcopy to insert new symbols into a file:
  --add-symbol <name>=[<section>:]<value>[,<flags>]

* Add support for the ARC EM/HS, and ARC600/700 architectures.

* Extend objcopy --compress-debug-sections option to support
  --compress-debug-sections=[none|zlib|zlib-gnu|zlib-gabi] for ELF
  targets.

* Add --update-section option to objcopy.

* Add --output-separator option to strings.

Changes in 2.25:

* Add --data option to strings to only print strings in loadable, initialized
  data sections.  Change the default behaviour to be --all, but add a new
  configure time option of --disable-default-strings-all to restore the old
  default behaviour.

* Add --include-all-whitespace to strings.

* Add --dump-section option to objcopy.

* Add support for the Andes NDS32.
2017-01-30 12:07:36 +00:00

24 lines
902 B
Text

$NetBSD: patch-ag,v 1.5 2017/01/30 12:07:36 mef Exp $
Avoid installing info (which duplicates with other CPU)
--- ld/Makefile.in.orig 2016-08-03 16:36:54.000000000 +0900
+++ ld/Makefile.in 2017-01-29 12:08:42.000000000 +0900
@@ -181,7 +181,7 @@ LTYACCCOMPILE = $(LIBTOOL) $(AM_LIBTOOLF
SOURCES = $(libldtestplug_la_SOURCES) $(libldtestplug2_la_SOURCES) \
$(libldtestplug3_la_SOURCES) $(libldtestplug4_la_SOURCES) \
$(ld_new_SOURCES) $(EXTRA_ld_new_SOURCES)
-INFO_DEPS = ld.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)/../texinfo
DVIS = ld.dvi
PDFS = ld.pdf
@@ -425,7 +425,7 @@ use_sysroot = @use_sysroot@
AUTOMAKE_OPTIONS = dejagnu no-texinfo.tex no-dist foreign
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
TEXINFO_TEX = ../texinfo/texinfo.tex
-SUBDIRS = po
+SUBDIRS =
tooldir = $(exec_prefix)/$(target_alias)
# Automake 1.10+ disables lex and yacc output file regeneration if