pkgsrc/devel/nss/patches/patch-mn
ryoon 3f0de48bfb Update to 3.19
Changelog:
The NSS team has released Network Security Services (NSS) 3.19,
which is a minor release.

New functionality:
* For some certificates, such as root CA certificates, that don't
  embed any constraints, NSS might impose additional constraints,
  such as name constraints. A new API has been added that allows
  to lookup imposed constraints.
* It is possible to override the directory in which the NSS build
  system will look for the sqlite library.

New Functions:
* CERT_GetImposedNameConstraints

Notable Changes:
* The SSL 3 protocol has been disabled by default.
* NSS now more strictly validates TLS extensions and will fail a
  handshake that contains malformed extensions.
* Fixed a bug related to the ordering of TLS handshake messages.
* In TLS 1.2 handshakes, NSS advertises support for the SHA512
  hash algorithm, in order to be compatible with TLS servers
  that use certificates with a SHA512 signature.
2015-05-05 21:42:19 +00:00

28 lines
861 B
Text

$NetBSD: patch-mn,v 1.3 2015/05/05 21:42:19 ryoon Exp $
Make sure we link correctly with sqlite3 from pkgsrc.
--- nss/lib/softoken/config.mk.orig 2015-04-30 20:00:23.000000000 +0000
+++ nss/lib/softoken/config.mk
@@ -22,8 +22,8 @@ RESNAME = $(LIBRARY_NAME).rc
ifdef NS_USE_GCC
EXTRA_SHARED_LIBS += \
- -L$(SQLITE_LIB_DIR) \
- -l$(SQLITE_LIB_NAME) \
+ `pkg-config --libs-only-L sqlite3` \
+ `pkg-config --libs-only-l sqlite3` \
-L$(NSSUTIL_LIB_DIR) \
-lnssutil3 \
-L$(NSPR_LIB_DIR) \
@@ -47,8 +47,8 @@ else
# $(PROGRAM) has NO explicit dependencies on $(EXTRA_SHARED_LIBS)
# $(EXTRA_SHARED_LIBS) come before $(OS_LIBS), except on AIX.
EXTRA_SHARED_LIBS += \
- -L$(SQLITE_LIB_DIR) \
- -l$(SQLITE_LIB_NAME) \
+ `pkg-config --libs-only-L sqlite3` \
+ `pkg-config --libs-only-l sqlite3` \
-L$(NSSUTIL_LIB_DIR) \
-lnssutil3 \
-L$(NSPR_LIB_DIR) \