pkgsrc/net/sysmon/patches/patch-aa
mef 11cd35348a Updated net/sysmon 0.92.2 to 0.93
---------------------------------
   Changes for 0.93
     * proper qsort crash fix
     * fix excessive logging when no IPv6 is available
     * add ability to ack objects
     * add ability to attach notes to objects
     * add ability for object to have a group
     * fix textfile display to properly account for deps
     * reduce excessive cpu usage watching wall clock
     * hrmph, qsort fix maybe?
     * stab at fix for timing issue with needssleep() (should reduce cpu usage)
2016-08-14 02:13:49 +00:00

35 lines
1 KiB
Text

$NetBSD: patch-aa,v 1.2 2016/08/14 02:13:49 mef Exp $
destdir support
--- autoconf/Makefile.in.orig 2009-12-13 14:50:15.000000000 +0100
+++ autoconf/Makefile.in 2009-12-13 14:52:57.000000000 +0100
@@ -19,6 +19,7 @@
LDFLAGS = @LDFLAGS@
RM = /bin/rm -f
+destdir = @destdir@
prefix = @prefix@
exec_prefix = @exec_prefix@
@@ -54,13 +55,13 @@
grep SYSM_VERS config.h | mail -s"Sysmon Registration" jared@puck.nether.net
install: all
- @echo "installing into @bindir@"
- -mkdir -p @bindir@
- -mv @bindir@/sysmond @bindir@/sysmond.old
- -mv @bindir@/sysmon @bindir@/sysmon.old
- cp sysmon sysmond @bindir@
- @echo "creating directory @sysconfdir@"
- -mkdir -p @sysconfdir@
+ @echo "installing into @destdir@/@bindir@"
+ -mkdir -p @destdir@/@bindir@
+ -mv @destdir@/@bindir@/sysmond @destdir@/@bindir@/sysmond.old
+ -mv @destdir@/@bindir@/sysmon @destdir@/@bindir@/sysmon.old
+ cp sysmon sysmond @destdir@/@bindir@
+ @echo "creating directory @destdir@/@sysconfdir@"
+ -mkdir -p @destdir@/@sysconfdir@
strip:
-strip @PROGS@