pkgsrc/graphics/MesaLib/patches/patch-be
hasso 1e744f5d32 Update to 7.4.4. Make software ratserizer actually work. Add one patch from
upstream repo to fix null pointer dereference.

Changes in 7.4.4:

* Fixed i965/i915 segfault in screen destruction (bug 22408)

Changes in 7.4.3:

* Fixed texture object reference counting bug (bug 21756)
* Allow depth/stencil textures to be attached to GL_STENCIL_ATTACHMENT
  point (SF bug 2793846)
* Added missing glGet case for GL_VERTEX_ARRAY_BINDING_APPLE
* Fixed some OSMesa build issues
* Fixed a vertex buffer object crash
* Fixed broken glTexImage3D() when image type = GL_BITMAP
* Fixed some GLSL preprocessor bugs
* Fixed framebuffer mem leak in i945/i965 DRI drivers
* Fixed texture coordinate repeat bug in swrast (bug 21872)
* Fixed incorrect viewport clamping (lower bound is zero, not one)
* GLX fix for glean's makeCurrent test case
2009-07-08 20:00:57 +00:00

39 lines
1.4 KiB
Text

$NetBSD: patch-be,v 1.2 2009/07/08 20:00:58 hasso Exp $
--- src/mesa/drivers/osmesa/Makefile.orig 2009-06-17 20:30:03 +0300
+++ src/mesa/drivers/osmesa/Makefile 2009-06-22 07:52:00 +0300
@@ -21,14 +21,15 @@ INCLUDE_DIRS = \
# Standalone osmesa needs to be linked with core Mesa APIs
ifeq ($(DRIVER_DIRS), osmesa)
-CORE_MESA = $(TOP)/src/mesa/libmesa.a $(TOP)/src/mesa/libglapi.a
+CORE_MESA = $(TOP)/src/mesa/libmesa.la $(TOP)/src/mesa/libglapi.la
else
CORE_MESA =
endif
.c.o:
- $(CC) -c $(INCLUDE_DIRS) $(CFLAGS) $< -o $@
+ $(LIBTOOL) --mode=compile --tag=CC $(CC) -c $(INCLUDE_DIRS) \
+ $(CFLAGS) $< -o $(@:.o=.lo)
default: $(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME)
@@ -38,11 +39,11 @@ default: $(TOP)/$(LIB_DIR)/$(OSMESA_LIB_
# sources. We can also build libOSMesa16/libOSMesa32 by setting
# -DCHAN_BITS=16/32.
$(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME): $(OBJECTS) $(CORE_MESA)
- $(MKLIB) -o $(OSMESA_LIB) -linker '$(CC)' -ldflags '$(LDFLAGS)' \
- -major $(MESA_MAJOR) -minor $(MESA_MINOR) -patch $(MESA_TINY) \
- -install $(TOP)/$(LIB_DIR) $(MKLIB_OPTIONS) \
- -id $(INSTALL_LIB_DIR)/lib$(OSMESA_LIB).$(MESA_MAJOR).dylib \
- $(OSMESA_LIB_DEPS) $(OBJECTS) $(CORE_MESA)
+ $(LIBTOOL) --mode=link $(CC) \
+ -o $(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME:.so=.la) $(LDFLAGS) \
+ -rpath $(PREFIX)/lib \
+ -version-info $(MESA_MAJOR):$(MESA_MINOR):0 \
+ $(OSMESA_LIB_DEPS) $(OBJECTS:.o=.lo) $(CORE_MESA)