This update consists of numerous bugfixes. See http://www.libsdl.org/release/changes-1.2.html for a full list.
124 lines
4.4 KiB
Text
124 lines
4.4 KiB
Text
$NetBSD: patch-aj,v 1.14 2002/10/13 19:28:58 kristerw Exp $
|
|
--- configure.in.orig Sun Oct 13 14:01:53 2002
|
|
+++ configure.in Sun Oct 13 20:41:57 2002
|
|
@@ -412,10 +412,7 @@
|
|
, enable_nas=yes)
|
|
if test x$enable_audio = xyes -a x$enable_nas = xyes; then
|
|
AC_MSG_CHECKING(for NAS audio support)
|
|
- have_nas=no
|
|
- if test -r /usr/X11R6/include/audio/audiolib.h; then
|
|
have_nas=yes
|
|
- fi
|
|
AC_MSG_RESULT($have_nas)
|
|
if test x$have_nas = xyes; then
|
|
CFLAGS="$CFLAGS -DNAS_SUPPORT"
|
|
@@ -488,7 +485,7 @@
|
|
NASMFLAGS="-f aoutb"
|
|
;;
|
|
*)
|
|
- NASMFLAGS="-f elf"
|
|
+ test -n "$NASMFLAGS" || NASMFLAGS="-f elf"
|
|
;;
|
|
esac
|
|
AC_SUBST(NASMFLAGS)
|
|
@@ -1104,12 +1101,13 @@
|
|
[ --enable-pth use GNU pth library for multi-threading [default=yes]],
|
|
, enable_pth=yes)
|
|
if test x$enable_threads = xyes -a x$enable_pth = xyes; then
|
|
- AC_PATH_PROG(PTH_CONFIG, pth-config, no)
|
|
- if test "$PTH_CONFIG" = "no"; then
|
|
+ # Use the libpthread version of the pth library.
|
|
+ AC_PATH_PROG(PTHREAD_CONFIG, pthread-config, no)
|
|
+ if test "$PTHREAD_CONFIG" = "no"; then
|
|
use_pth=no
|
|
else
|
|
- PTH_CFLAGS=`$PTH_CONFIG --cflags`
|
|
- PTH_LIBS=`$PTH_CONFIG --libs --all`
|
|
+ PTH_CFLAGS=`$PTHREAD_CONFIG --cflags`
|
|
+ PTH_LIBS=`$PTHREAD_CONFIG --libs --all`
|
|
SDL_CFLAGS="$SDL_CFLAGS $PTH_CFLAGS"
|
|
SDL_LIBS="$SDL_LIBS $PTH_LIBS"
|
|
CFLAGS="$CFLAGS -DENABLE_PTH"
|
|
@@ -1150,8 +1148,8 @@
|
|
pthread_lib="-pthread"
|
|
;;
|
|
*-*-netbsd*)
|
|
- pthread_cflags="-I/usr/pkg/include -D_REENTRANT"
|
|
- pthread_lib="-L/usr/pkg/lib -lpthread -lsem"
|
|
+ pthread_cflags="-D_REENTRANT"
|
|
+ pthread_lib="-lpthread"
|
|
;;
|
|
*-*-openbsd*)
|
|
pthread_cflags="-D_REENTRANT"
|
|
@@ -1566,29 +1564,31 @@
|
|
have_libusbhid=no
|
|
have_libusb=no
|
|
AC_CHECK_LIB(usbhid, hid_init, have_libusbhid=yes)
|
|
- AC_CHECK_LIB(usb, hid_init, have_libusb=yes)
|
|
if test x$have_libusbhid = xyes; then
|
|
SYSTEM_LIBS="$SYSTEM_LIBS -lusbhid"
|
|
+
|
|
+ AC_CHECK_HEADER(usbhid.h, have_usbhid_h=yes)
|
|
+ AC_CHECK_HEADER(libusbhid.h, have_libusbhid_h=yes)
|
|
+ if test x$have_usbhid_h = xyes; then
|
|
+ CFLAGS="$CFLAGS -DHAVE_USBHID_H"
|
|
+ fi
|
|
+ if test x$have_libusbhid_h = xyes; then
|
|
+ CFLAGS="$CFLAGS -DHAVE_LIBUSBHID_H"
|
|
fi
|
|
+ else
|
|
+ AC_CHECK_LIB(usb, hid_init, have_libusb=yes)
|
|
if test x$have_libusb = xyes; then
|
|
SYSTEM_LIBS="$SYSTEM_LIBS -lusb"
|
|
- fi
|
|
|
|
AC_CHECK_HEADER(usb.h, have_usb_h=yes)
|
|
- AC_CHECK_HEADER(usbhid.h, have_usbhid_h=yes)
|
|
AC_CHECK_HEADER(libusb.h, have_libusb_h=yes)
|
|
- AC_CHECK_HEADER(libusbhid.h, have_libusbhid_h=yes)
|
|
if test x$have_usb_h = xyes; then
|
|
CFLAGS="$CFLAGS -DHAVE_USB_H"
|
|
fi
|
|
- if test x$have_usbhid_h = xyes; then
|
|
- CFLAGS="$CFLAGS -DHAVE_USBHID_H"
|
|
- fi
|
|
if test x$have_libusb_h = xyes; then
|
|
CFLAGS="$CFLAGS -DHAVE_LIBUSB_H"
|
|
fi
|
|
- if test x$have_libusbhid_h = xyes; then
|
|
- CFLAGS="$CFLAGS -DHAVE_LIBUSBHID_H"
|
|
+ fi
|
|
fi
|
|
|
|
AC_MSG_CHECKING(for usbhid)
|
|
@@ -1834,6 +1834,7 @@
|
|
CheckESD
|
|
CheckNAS
|
|
CheckX11
|
|
+ CheckDGA
|
|
CheckAAlib
|
|
CheckOpenGL
|
|
CheckPTHREAD
|
|
@@ -1842,9 +1843,9 @@
|
|
COPY_ARCH_SRC(src/main, linux, SDL_main.c)
|
|
# Set up files for the audio library
|
|
if test x$enable_audio = xyes; then
|
|
- CFLAGS="$CFLAGS -DSUNAUDIO_SUPPORT"
|
|
- AUDIO_SUBDIRS="$AUDIO_SUBDIRS sun"
|
|
- AUDIO_DRIVERS="$AUDIO_DRIVERS sun/libaudio_sun.la"
|
|
+ CFLAGS="$CFLAGS -DOPENBSD_AUDIO_SUPPORT"
|
|
+ AUDIO_SUBDIRS="$AUDIO_SUBDIRS openbsd"
|
|
+ AUDIO_DRIVERS="$AUDIO_DRIVERS openbsd/libaudio_openbsd.la"
|
|
fi
|
|
# Set up files for the cdrom library
|
|
if test x$enable_cdrom = xyes; then
|
|
@@ -2483,6 +2484,9 @@
|
|
fi
|
|
if test $ARCH = solaris; then
|
|
SDL_RLD_FLAGS="-R\${exec_prefix}/lib"
|
|
+fi
|
|
+if test $ARCH = netbsd; then
|
|
+ SDL_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib -Wl,-rpath,${X11BASE}/lib"
|
|
fi
|
|
|
|
case "$ARCH" in
|