ca70938428
which are the full option names used to set rpath directives for the linker and the compiler, respectively. In places were we are invoking the linker, use "${LINKER_RPATH_FLAG} <path>", where the space is inserted in case the flag is a word, e.g. -rpath. The default values of *_RPATH_FLAG are set by the compiler/*.mk files, depending on the compiler that you use. They may be overridden on a ${OPSYS}-specific basis by setting _OPSYS_LINKER_RPATH_FLAG and _OPSYS_COMPILER_RPATH_FLAG, respectively. Garbage-collect _OPSYS_RPATH_NAME and _COMPILER_LD_FLAG.
12 lines
443 B
Text
12 lines
443 B
Text
$NetBSD: patch-ab,v 1.6 2004/08/27 06:29:08 jlam Exp $
|
|
|
|
--- gcc/Makefile.in.orig Tue Jan 28 16:54:07 2003
|
|
+++ gcc/Makefile.in Sat May 24 13:01:38 2003
|
|
@@ -1236,6 +1236,7 @@
|
|
# Language-independent files.
|
|
|
|
DRIVER_DEFINES = \
|
|
+ -DLINK_LIBGCC_SPEC="\"%D $(LINKER_RPATH_FLAG) $(prefix)/lib\"" \
|
|
-DSTANDARD_STARTFILE_PREFIX=\"$(unlibsubdir)/\" \
|
|
-DSTANDARD_EXEC_PREFIX=\"$(libdir)/gcc-lib/\" \
|
|
-DDEFAULT_TARGET_VERSION=\"$(version)\" \
|