6a2b156325
PHP 7.2.x builds upon 7.1.x, adding new features: * Argument type declarations * Object return type declarations * Parameter Type Widening * Trailing commas in list syntax * Argon2 in password hash * Libsodium as part of PHP Core * Deprecated: __autoload, $php_errormsg, create_function(), mbstring.func_overload, parse_str() without second argument, gmp_random(), each(), assert(), $errcontext * uniqid() patch to avoid usleep() integrated, 10000x improvement on NetBSD, about 10x on Linux
13 lines
666 B
JavaScript
13 lines
666 B
JavaScript
$NetBSD: patch-ext_phar_Makefile.frag,v 1.1 2017/11/15 08:56:12 jdolecek Exp $
|
|
|
|
--- ext/phar/Makefile.frag.orig 2015-06-23 17:33:33.000000000 +0000
|
|
+++ ext/phar/Makefile.frag
|
|
@@ -18,7 +18,7 @@ PHP_PHARCMD_EXECUTABLE = ` \
|
|
else \
|
|
$(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
|
|
fi;`
|
|
-PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
+PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
|
|
$(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
|
|
-@test -d $(builddir)/phar || mkdir $(builddir)/phar
|