60c5a78963
Originally supplied by collver@linuxfreemail.com in pkg/14359 and subsequently modified somewhat mostly by him.
42 lines
1.1 KiB
Text
42 lines
1.1 KiB
Text
$NetBSD: patch-ba,v 1.1.1.1 2002/01/21 11:56:17 pooka Exp $
|
|
|
|
--- sys/unix/Makefile.src.orig Sun Jun 24 18:57:24 2001
|
|
+++ sys/unix/Makefile.src
|
|
@@ -146,7 +146,7 @@
|
|
# directories. You should have sdl-config in your path; it gives the
|
|
# necessary compile and link flags.
|
|
#
|
|
-JTPINC=$(shell sdl-config --cflags)
|
|
+JTPINC!=sdl-config --cflags
|
|
|
|
# flags for debugging:
|
|
# CFLAGS = -g -I../include
|
|
@@ -218,8 +218,8 @@
|
|
|
|
#
|
|
#
|
|
-WINSRC = $(WINTTYSRC) $(WINJTPSRC)
|
|
-WINOBJ = $(WINTTYOBJ) $(WINJTPOBJ)
|
|
+WINSRC = $(WINJTPSRC)
|
|
+WINOBJ = $(WINJTPOBJ)
|
|
|
|
# on some systems the termcap library is in -ltermcap or -lcurses
|
|
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
|
@@ -239,7 +239,7 @@
|
|
#
|
|
|
|
# SDL libraries for Falcon's Eye
|
|
-WINJTPLIB = $(shell sdl-config --libs)
|
|
+WINJTPLIB!=sdl-config --libs
|
|
|
|
#
|
|
# libraries for X11
|
|
@@ -264,7 +264,7 @@
|
|
# libraries for BeOS
|
|
WINBELIB = -lbe
|
|
|
|
-WINLIB = $(WINTTYLIB) $(WINJTPLIB)
|
|
+WINLIB = $(WINJTPLIB)
|
|
|
|
# any other strange libraries your system needs (for Sysunix only -- the more
|
|
# specialized targets should already be right)
|