pkgsrc/x11/fltk/patches/patch-ab
obache 991df8e06d Update fltk to 1.1.10.
Based on patch from Tim Larson by PR#43061.

CHANGES IN FLTK 1.1.10

	- Widgets now remove stale entries from the default callback
	  queue when they are deleted (STR #2302)
	- Fixed selection bug in Fl_Int_Input (STR #2292)
	- Fixed character set conversion functions (STR #2268)
	- Fixed image lib configure and fltk-config issues by backporting
	  the image lib and zlib configure code from FLTK 1.3 (STR #2203)
	- Updated the bundled libpng to v1.2.40 (released Sep. 10, 2009)
	- Fixed Fl_Choice contrast with light-on-dark settings (STR #2219)
	- Added Xft2 font lookup table (STR #2215)
	- Fixed X server "lock", if a modal dialog window is opened
	  while a menu is active (STR #1986)
	- Updated mirror sites in documentation (STR #2220)
	- Setting a default font for Xft (STR #2216)
	- Temporarily limited builds to 32-bit on OX S to stay
	  compatible to Snow Leopard
	- Fixed Windows compile bug with "#define USE_COLORMAP 0"
	  (STR #2241)
	- Fixed glibc 2.10 compiler problems (Fedora 11 and others)
	  with scandir() and strchr() (STR #2222)
	- Fixed OpenGL shared context handling (STR #2135)
	- Fixed gray-scale images with alpha channel (STR #2105)
	- Fixed unexpected shortcut behavior for Win32 (STR #2199)
	- Added cast to Fl_Color in all Fluid code (STR #2206)
	- Fixed wrong identifier for special keys combined with
	  modifier (STR #2196)
	- Fixed documentation for Fl_Progress (STR #2209)
	- Fix for multiple popups, when dragging and calling fl_alert()
	  and friends from the callback (STR #2159)
	- Avoiding crashes for recursive common dialogs (this does not
	  fix the issue at hand yet) (STR 2150)
	- Fluid printing used wrong colors under Windows (STR #2195)
	- Fixed bad system menu hadling in OS X (STR #2153)
	- Fixed File Input mouse pointer dragging (STR #2181)
	- Added Fl_Scroll::bbox() documentation (STR #1893)
	- Fixed static linking of image libraries (STR #1962)
	- Fixed callback would not be called when shortcut was used with
          radio and toggle buttons in default FL_RELEASE mode.
	- Fixed a problem with TrackMouseEvent() (Windows only) that would
	  generate wrong FL_LEAVE events with subwindows. TrackMouseEvent
	  is now enabled by default (it was disabled for GNU compilers).
	  It can be disabled by defining NO_TRACK_MOUSE.
	  Improved test/subwindow.cxx (STR #2079)
	- Fixed RGB colors for round box (STR #2097)
	- Fixed documentation (added missing COMCTRL32.LIB dependency)
	- Fl_Group::clip_children() is now public (STR #2017)
	- Fixed first modifier key event (STR #1952)
	- Fixed wrong default value of Fl_Spinner in Fluid (STR #1991)
	- Fixed Fluid textcolor output (STR #1992)
	- Added clarification to Fl_GL_Window mode function (STR #1945)
	- Fl_Group and Fl_Scroll now resize themselves before
	  resizing their children (STR #2032)
	- Fixed adding an idle handler during a draw() call (STR #1950)
	- Improved stability of fl_read_image (STR #2021)
	- Fixed menu position close to screen border (STR #2057)
2010-04-09 13:35:41 +00:00

50 lines
1.5 KiB
Text

$NetBSD: patch-ab,v 1.13 2010/04/09 13:35:42 obache Exp $
--- configure.in.orig 2009-09-20 17:25:25.000000000 +0000
+++ configure.in
@@ -122,6 +122,7 @@ AC_SUBST(GLLIBNAME)
AC_SUBST(IMGLIBNAME)
AC_SUBST(LIBEXT)
AC_SUBST(LIBNAME)
+AC_SUBST(LIBTOOL)
AC_SUBST(LINKFLTK)
AC_SUBST(LINKFLTKFORMS)
AC_SUBST(LINKFLTKGL)
@@ -143,6 +144,15 @@ fi
AC_ARG_ENABLE(gl, [ --enable-gl turn on OpenGL support [default=yes]])
AC_ARG_ENABLE(shared, [ --enable-shared turn on shared libraries [default=no]])
+AC_ARG_ENABLE(libtool, [ --enable-libtool=LIBTOOL_PATH
+ turn on building with libtool [default=no]],[
+if eval "test x$enable_libtool != xno"; then
+ LIBTOOL="$enable_libtool"
+ enable_shared=no
+else
+ LIBTOOL=""
+fi])
+
if test x$enable_shared = xyes; then
PICFLAG=1
SHAREDSUFFIX=""
@@ -261,6 +271,21 @@ else
FLUID="fluid"
LINKSHARED="../lib/libfltk_images.a ../lib/libfltk_forms.a ../lib/libfltk.a"
fi
+if test "x$LIBTOOL" != "x"; then
+ LINKFLTK="../src/libfltk.la"
+ if test "x$LINKFLTKGL" != "x"; then
+ LINKFLTKGL="../src/libfltk_gl.la"
+ fi
+ if test "x$LINKFLTKIMG" != "x"; then
+ LINKFLTKIMG="../src/libfltk_images.la"
+ fi
+ LINKSHARED="-lfltk_images -lfltk_forms -lfltk"
+ DSONAME="libfltk.la"
+ FLDSONAME="libfltk_forms.la"
+ GLDSONAME="libfltk_gl.la"
+ IMGDSONAME="libfltk_images.la"
+fi
+
AC_SUBST(DSOCOMMAND)
AC_SUBST(DSOFLAGS)