8a11fad5d6
- Add dependency on autoconf and have auto{header,conf} run at pre-configure stage: this is need to avoid conflict between the distribution patch file for IPv6 and patch files. - Pave the way for the removal of PERL5_GENERATE_PLIST from bsd.pkg.mk: use perl5/module.mk with PERL5_CONFIGURE=NO. - Ensure relocatable objects are created so that when the Perl modules are linked they are composed wholly from relocatable objects. We query perl for how to compile a source file into a relocatable object file. Thanks again jlam for this.
15 lines
419 B
Text
15 lines
419 B
Text
$NetBSD: patch-ah,v 1.1 2002/11/15 11:49:08 seb Exp $
|
|
|
|
--- perl/sieve/lib/Makefile.in.orig Sat May 25 21:57:50 2002
|
|
+++ perl/sieve/lib/Makefile.in
|
|
@@ -55,8 +55,8 @@ LIBS = ../../../lib/libcyrus.a @LIB_DYN_
|
|
IMAP_LIBS = @IMAP_LIBS@
|
|
DEPLIBS = ../../../lib/libcyrus.a @DEPLIBS@
|
|
|
|
-CFLAGS = -g
|
|
-LDFLAGS = -g @LDFLAGS@
|
|
+CFLAGS = @CFLAGS@ @PERL_CCCDLFLAGS@
|
|
+LDFLAGS = @LDFLAGS@
|
|
|
|
SHELL = /bin/sh
|
|
MAKEDEPEND = @MAKEDEPEND@
|