ba93f617f3
NOTE: The names of the default configuration files has changed. They now end in `.cfg' or `.sym'. Approved by MAINTAINER. Changes since last packaged version: * 4-3-2003 flow-tools-0.66 released * reapply flow-fanout linux patch, also infected flow-send * 4-3-2003 flow-tools-0.65 released * flow-send, flow-fanout: -s source IP address spoofing. * build: builddir != srcdir problems - noted by jos@catnook.com * build: All default config files installed by default. * build: config files end in .cfg, symbol files end in .sym. Note this changes the names of the default configuration files. * ftlib: ftfil.c - random sample filter - reqested by Edward Balas <ebalas@iu.edu> * ftlib: ftstat.c - ip-destination-address-source-count missing count - noted by Christian Cinetto <cinetto@garr.it> * build: example tags file installed by default. * ftlib: ftstat.c - broken ip-source-address/ip-destination-port - noted by Gerhard.Haindl@t-systems.at * ftlib: ftstat.c - broken ip-destination-address/destination-as - noted by carsten.strahler@lambdanet.net * remove bin scripts (mostly historical OSU stuff) * upgrade to automake 1.7.3 and autoconf 2.57 * docs: flow-report.sgml missing ip-source/destination-address/ip-protocol/ip-tos/ip-source/destination-port noted by shane.dawalt@wright.edu * flow-fanout: will not compile under linux - patch from alex.shepard@gettyimages.com * ftlib: ftstat.c - use FMT_SYM_LEN instead of hard coded 32 byte length. increase len to 64 bytes. * ftlib: fmt.c - fmt_uint*s() did not properly null terminate when symbol strlen >= max - noted by jed@onenet.net * 2-23-2003 flow-tools-0.64 released * flow-fanout, flow-capture, flow-receive: add startup= to STAT: line * docs: flow-fanout - missing -f -F - noted by RAR@syssrc.com * flow-split: consuming too many resources, noted by fin@finseth.com * ftlib: ftstat.c - rec2: in summary-detail report missing time_real field - noted by shane.dawalt@wright.edu * build: strouq() -> strtoull(). Check if strtoul() is really strtoull() - noted by shane.dawalt@wright.edu * ftlib: ftstat.c - protect potential divide by 0 errors - noted by shane.dawalt@wright.edu * flow-split: stag not initialized - patch from fin@finseth.com * build: ftlib.h should not require ftconfig.h - noted by jan@kneschke.de * build: lib/ftconfig.h does not belong in dist - noted by jos@catnook.com * ftlib: ftlib.h - FT_SO_RCV_BUFSIZE default to 4MB * ftlib: suppport.c - bigsockbuf() - more agressive reduction on large buffers. Report size. * ftlib: ftmask.c - flow-mask: rn_deladdr(): failed. Missing masklen set - noted by nik.hinson@assurance-dynamics.com * ftlib: ftfil.c - invert option to filter-definition req by mhyde@escape.ca * ftlib: shadowed variable names - fumerola@yahoo-inc.com * flow-cat: exit status 1 if no streams processed - req by mhunter@ack.Berkeley.EDU * ftlib: ftstat.c - bucket_dump_1(): loop typo noted by nik.hinson@assurance-dynamics.com * flow-capture: reload tags and filters with SIGHUP * flow-import: format4 wire format. * ftlib: ftstat.c - tag mask option should not require local tagging - noted by clay@bloomcounty.org * flow-*: catch extra command line args - noted by rcarrara@augustmail.com * ftlib: fttag.c - fix ToS tagging, add ANY tagging.
206 lines
9.3 KiB
Text
206 lines
9.3 KiB
Text
$NetBSD: patch-af,v 1.2 2003/05/23 07:19:44 seb Exp $
|
|
|
|
--- lib/Makefile.in.orig 2003-05-22 13:32:03.000000000 +0000
|
|
+++ lib/Makefile.in
|
|
@@ -120,7 +120,7 @@ target_alias = @target_alias@
|
|
#AM_CFLAGS=-O2
|
|
AM_CFLAGS = -g -Wall
|
|
|
|
-include_HEADERS = ftlib.h ftqueue.h radix.h ftpaths.h ftconfig.h
|
|
+pkginclude_HEADERS = ftlib.h ftqueue.h radix.h ftpaths.h ftconfig.h
|
|
lib_LIBRARIES = libft.a
|
|
|
|
libft_a_SOURCES = ftio.c ftswap.c ftencode.c ftdecode.c ftprof.c bit1024.c \
|
|
@@ -149,30 +149,17 @@ am_libft_a_OBJECTS = ftio.$(OBJEXT) ftsw
|
|
libft_a_OBJECTS = $(am_libft_a_OBJECTS)
|
|
|
|
DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
|
|
-depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
-am__depfiles_maybe = depfiles
|
|
-@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/strerror.Po $(DEPDIR)/strsep.Po \
|
|
-@AMDEP_TRUE@ $(DEPDIR)/strtoull.Po ./$(DEPDIR)/bit1024.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/fmt.Po ./$(DEPDIR)/ftchash.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/ftdecode.Po ./$(DEPDIR)/ftencode.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/fterr.Po ./$(DEPDIR)/ftfil.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/ftfile.Po ./$(DEPDIR)/ftio.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/ftmap.Po ./$(DEPDIR)/ftmask.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/ftprof.Po ./$(DEPDIR)/ftrec.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/ftstat.Po ./$(DEPDIR)/ftswap.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/ftsym.Po ./$(DEPDIR)/fttag.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/fttlv.Po ./$(DEPDIR)/ftvar.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/ftxfield.Po ./$(DEPDIR)/getdate.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/radix.Po ./$(DEPDIR)/support.Po
|
|
+depcomp =
|
|
+am__depfiles_maybe =
|
|
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
|
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
|
CCLD = $(CC)
|
|
LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
DIST_SOURCES = $(libft_a_SOURCES)
|
|
-HEADERS = $(include_HEADERS)
|
|
+HEADERS = $(pkginclude_HEADERS)
|
|
|
|
-DIST_COMMON = $(include_HEADERS) Makefile.am Makefile.in ftconfig.h.in \
|
|
- ftpaths.h.in strerror.c strsep.c strtoull.c
|
|
+DIST_COMMON = $(pkginclude_HEADERS) Makefile.am Makefile.in \
|
|
+ ftconfig.h.in ftpaths.h.in strerror.c strsep.c strtoull.c
|
|
SOURCES = $(libft_a_SOURCES)
|
|
|
|
all: ftconfig.h
|
|
@@ -182,7 +169,7 @@ all: ftconfig.h
|
|
.SUFFIXES: .c .o .obj
|
|
$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
|
|
cd $(top_srcdir) && \
|
|
- $(AUTOMAKE) --gnu lib/Makefile
|
|
+ $(AUTOMAKE) --foreign --ignore-deps lib/Makefile
|
|
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
|
|
|
|
@@ -247,75 +234,29 @@ mostlyclean-compile:
|
|
distclean-compile:
|
|
-rm -f *.tab.c
|
|
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/strerror.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/strsep.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/strtoull.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bit1024.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/fmt.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftchash.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftdecode.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftencode.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/fterr.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftfil.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftfile.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftio.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftmap.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftmask.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftprof.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftrec.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftstat.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftswap.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftsym.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/fttag.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/fttlv.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftvar.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ftxfield.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getdate.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/radix.Po@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/support.Po@am__quote@
|
|
-
|
|
-distclean-depend:
|
|
- -rm -rf $(DEPDIR) ./$(DEPDIR)
|
|
-
|
|
.c.o:
|
|
-@am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
|
|
-@am__fastdepCC_TRUE@ -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \
|
|
-@am__fastdepCC_TRUE@ then mv "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
|
|
-@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
|
|
-@am__fastdepCC_TRUE@ fi
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
-@am__fastdepCC_FALSE@ $(COMPILE) -c `test -f '$<' || echo '$(srcdir)/'`$<
|
|
+ $(COMPILE) -c `test -f '$<' || echo '$(srcdir)/'`$<
|
|
|
|
.c.obj:
|
|
-@am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
|
|
-@am__fastdepCC_TRUE@ -c -o $@ `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`; \
|
|
-@am__fastdepCC_TRUE@ then mv "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
|
|
-@am__fastdepCC_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
|
|
-@am__fastdepCC_TRUE@ fi
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
-@am__fastdepCC_FALSE@ $(COMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`
|
|
+ $(COMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`
|
|
uninstall-info-am:
|
|
-includeHEADERS_INSTALL = $(INSTALL_HEADER)
|
|
-install-includeHEADERS: $(include_HEADERS)
|
|
+pkgincludeHEADERS_INSTALL = $(INSTALL_HEADER)
|
|
+install-pkgincludeHEADERS: $(pkginclude_HEADERS)
|
|
@$(NORMAL_INSTALL)
|
|
- $(mkinstalldirs) $(DESTDIR)$(includedir)
|
|
- @list='$(include_HEADERS)'; for p in $$list; do \
|
|
+ $(mkinstalldirs) $(DESTDIR)$(pkgincludedir)
|
|
+ @list='$(pkginclude_HEADERS)'; for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
|
- echo " $(includeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(includedir)/$$f"; \
|
|
- $(includeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(includedir)/$$f; \
|
|
+ echo " $(pkgincludeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
+ $(pkgincludeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(pkgincludedir)/$$f; \
|
|
done
|
|
|
|
-uninstall-includeHEADERS:
|
|
+uninstall-pkgincludeHEADERS:
|
|
@$(NORMAL_UNINSTALL)
|
|
- @list='$(include_HEADERS)'; for p in $$list; do \
|
|
+ @list='$(pkginclude_HEADERS)'; for p in $$list; do \
|
|
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
|
- echo " rm -f $(DESTDIR)$(includedir)/$$f"; \
|
|
- rm -f $(DESTDIR)$(includedir)/$$f; \
|
|
+ echo " rm -f $(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
+ rm -f $(DESTDIR)$(pkgincludedir)/$$f; \
|
|
done
|
|
|
|
ETAGS = etags
|
|
@@ -408,7 +349,7 @@ check: check-am
|
|
all-am: Makefile $(LIBRARIES) $(HEADERS) ftconfig.h
|
|
|
|
installdirs:
|
|
- $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
|
|
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(pkgincludedir)
|
|
|
|
install: install-am
|
|
install-exec: install-exec-am
|
|
@@ -440,8 +381,8 @@ clean-am: clean-generic clean-libLIBRARI
|
|
|
|
distclean: distclean-am
|
|
|
|
-distclean-am: clean-am distclean-compile distclean-depend \
|
|
- distclean-generic distclean-hdr distclean-tags
|
|
+distclean-am: clean-am distclean-compile distclean-generic distclean-hdr \
|
|
+ distclean-tags
|
|
|
|
dvi: dvi-am
|
|
|
|
@@ -451,7 +392,7 @@ info: info-am
|
|
|
|
info-am:
|
|
|
|
-install-data-am: install-includeHEADERS
|
|
+install-data-am: install-pkgincludeHEADERS
|
|
|
|
install-exec-am: install-libLIBRARIES
|
|
|
|
@@ -477,21 +418,21 @@ ps: ps-am
|
|
|
|
ps-am:
|
|
|
|
-uninstall-am: uninstall-includeHEADERS uninstall-info-am \
|
|
- uninstall-libLIBRARIES
|
|
+uninstall-am: uninstall-info-am uninstall-libLIBRARIES \
|
|
+ uninstall-pkgincludeHEADERS
|
|
|
|
.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
|
|
clean-libLIBRARIES ctags distclean distclean-compile \
|
|
- distclean-depend distclean-generic distclean-hdr distclean-tags \
|
|
- distdir dvi dvi-am info info-am install install-am install-data \
|
|
- install-data-am install-exec install-exec-am \
|
|
- install-includeHEADERS install-info install-info-am \
|
|
- install-libLIBRARIES install-man install-strip installcheck \
|
|
+ distclean-generic distclean-hdr distclean-tags distdir dvi \
|
|
+ dvi-am info info-am install install-am install-data \
|
|
+ install-data-am install-exec install-exec-am install-info \
|
|
+ install-info-am install-libLIBRARIES install-man \
|
|
+ install-pkgincludeHEADERS install-strip installcheck \
|
|
installcheck-am installdirs maintainer-clean \
|
|
maintainer-clean-generic mostlyclean mostlyclean-compile \
|
|
mostlyclean-generic pdf pdf-am ps ps-am tags uninstall \
|
|
- uninstall-am uninstall-includeHEADERS uninstall-info-am \
|
|
- uninstall-libLIBRARIES
|
|
+ uninstall-am uninstall-info-am uninstall-libLIBRARIES \
|
|
+ uninstall-pkgincludeHEADERS
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|