403a021f1c
Included are three new patches to make it compile with gcc4, to fix a bug in an emulated instruction and to increase the memory size of the emulated system. 2006-10-27 Hartmut Brandt <harti@freebsd.org> * version 2.10i * Remove rl debugging prints * Fix a problem with IE in the TM CSR (submitted by Mike Haertel) * get rid of float_t - all *_t identifiers are reserved by posix! 2002-09-03 Hartmut Brandt <brandt@fokus.gmd.de> * rename libdir to libpath * libdir is now a colon separated path of directories that defaults to :/etc:${datadir}/p11 * implement an accessp() predicate to apply access(2) in a list of directories * further tweaks to the rpm spec file 2002-09-02 Hartmut Brandt <brandt@fokus.gmd.de> * p11.spec, p11.sh and some tweaks to build rpms. 2002-08-14 Hartmut Brandt <brandt@fokus.gmd.de> * main.c: implement daemonizing by specifying the -d option. * spot a gcc-3.1 error: Use of global registers generates bad code on the i386 for the MTPI instruction. Use --disable-regs for these platforms. 2002-03-07 Hartmut Brandt <brandt@fokus.gmd.de> * float.h (FrExp): the result of this macro should be signed, so make the exponent signed before subtracting the offset. Spotted by: Frank Wortner * proc.h: include <time.h> to get localtime declaration. Spotted by: imil@home.imil.net. * README: Add MacOS-X 10.1. Reported by: Christian Groessler. 2001-06-19 Hartmut Brandt <brandt@fokus.gmd.de> * float.h (GetMant): Replace a u_quad_t by u_xquad_t. * README: Add Slackware 7.1 Reformat paragraph.
13 lines
298 B
Text
13 lines
298 B
Text
$NetBSD: patch-aa,v 1.1 2007/01/27 12:02:16 wiz Exp $
|
|
|
|
--- instruct.c.orig 2000-12-04 18:03:41.000000000 +0100
|
|
+++ instruct.c 2006-04-18 02:21:40.000000000 +0200
|
|
@@ -107,7 +107,7 @@
|
|
}
|
|
void NEGB(void) {
|
|
dst = -dst;
|
|
- TestW(dst);
|
|
+ TestB(dst);
|
|
proc.c = (dst != 0);
|
|
proc.v = (dst == 0200);
|
|
}
|