c1f46e5893
Changes: * SDL no longer sets a fatal signal handler for SIGPIPE * Fixed modifier key state on MacOS X * Added support for remote XVideo * Fixed static linking on MacOS X * Fixed compiling with broken Linux 2.6 headers * Fixed mouse cursor visibility and focus events on MacOS X * Added support for /dev/joy* on Free/Net/OpenBSD * Fixed problems with CD-ROM audio playback on MacOS X 10.1 * Added dynamic GL library loading to MacOS Carbon support * Added function to create RWops from const memory: SDL_RWFromConstMem() * Fixed build problems with newer versions of automake * Fixed MacOS X libtool framework support * Added CPU feature detection functions to SDL_cpuinfo.h * Fixed illegal instruction crash using 3DNow on Intel processors * Fixed asm issues with mmx.h and gcc 3.3 * Fixed crash calling app defined window proc * Fixed long long constant warnings in GCC 3.3.1 * Fixed joystick open problems on BSD * Fixed X11 mode line crash with only one video mode Fixes PR pkg/22462. Okayed by wiz@.
21 lines
988 B
Text
21 lines
988 B
Text
$NetBSD: patch-bb,v 1.2 2004/04/17 00:15:21 snj Exp $
|
|
|
|
--- src/audio/esd/Makefile.in.orig 2004-02-22 13:32:08.000000000 -0800
|
|
+++ src/audio/esd/Makefile.in 2004-04-10 14:54:04.000000000 -0700
|
|
@@ -49,6 +49,7 @@ am__configure_deps = $(am__aclocal_m4_de
|
|
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
CONFIG_CLEAN_FILES =
|
|
LTLIBRARIES = $(noinst_LTLIBRARIES)
|
|
+libaudio_esd_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(ESD_LIBS)
|
|
libaudio_esd_la_LIBADD =
|
|
am__objects_1 = SDL_esdaudio.lo
|
|
am_libaudio_esd_la_OBJECTS = $(am__objects_1)
|
|
@@ -317,7 +318,7 @@ clean-noinstLTLIBRARIES:
|
|
rm -f "$${dir}/so_locations"; \
|
|
done
|
|
libaudio_esd.la: $(libaudio_esd_la_OBJECTS) $(libaudio_esd_la_DEPENDENCIES)
|
|
- $(LINK) $(libaudio_esd_la_LDFLAGS) $(libaudio_esd_la_OBJECTS) $(libaudio_esd_la_LIBADD) $(LIBS)
|
|
+ $(LINK) -rpath $(libdir) $(libaudio_esd_la_LDFLAGS) $(libaudio_esd_la_OBJECTS) $(libaudio_esd_la_LIBADD) $(LIBS)
|
|
|
|
mostlyclean-compile:
|
|
-rm -f *.$(OBJEXT)
|