pkgsrc/www/htdig-devel/patches/patch-ai
markd 9da2f19245 Import of latest htdig beta release (from 18 months ago) as htdig-devel.
The ht://Dig system is a complete world wide web indexing and searching
system for a small domain or intranet.

Imported during the freeze as its needed to fix a problem in kdebase3.
OKed by wiz.
2005-12-17 19:26:26 +00:00

28 lines
2.7 KiB
Text

$NetBSD: patch-ai,v 1.1.1.1 2005/12/17 19:26:26 markd Exp $
--- installdir/Makefile.in.orig 2005-12-15 01:15:44.000000000 +1300
+++ installdir/Makefile.in
@@ -496,10 +496,10 @@ uninstall-man: uninstall-man1 uninstall-
install-data-local: all
$(mkinstalldirs) $(DESTDIR)$(DATABASE_DIR)
@echo "Installing default configuration files..."
- $(mkinstalldirs) $(DESTDIR)$(CONFIG_DIR)
- @if [ ! -f $(DESTDIR)$(CONFIG_DIR)/htdig.conf ]; then sed -e s%@\DATABASE_DIR@%$(DATABASE_DIR)% -e s%@\IMAGEDIR@%$(IMAGE_URL_PREFIX)% $(top_srcdir)/installdir/htdig.conf >$(DESTDIR)$(CONFIG_DIR)/htdig.conf; echo $(DESTDIR)$(CONFIG_DIR)/htdig.conf;fi
- @if [ ! -f $(DESTDIR)$(CONFIG_DIR)/mime.types ]; then cp $(top_srcdir)/installdir/mime.types $(DESTDIR)$(CONFIG_DIR)/mime.types; echo $(DESTDIR)$(CONFIG_DIR)/mime.types;fi
- @if [ ! -f $(DESTDIR)$(CONFIG_DIR)/HtFileType-magic.mime ]; then cp $(top_srcdir)/installdir/HtFileType-magic.mime $(DESTDIR)$(CONFIG_DIR)/HtFileType-magic.mime; echo $(DESTDIR)$(CONFIG_DIR)/HtFileType-magic.mime;fi
+ $(mkinstalldirs) $(DESTDIR)$(SEARCH_DIR)
+ @if [ ! -f $(DESTDIR)$(SEARCH_DIR)/htdig.conf ]; then sed -e s%@\DATABASE_DIR@%$(DATABASE_DIR)% -e s%@\IMAGEDIR@%$(IMAGE_URL_PREFIX)% $(top_srcdir)/installdir/htdig.conf >$(DESTDIR)$(SEARCH_DIR)/htdig.conf; echo $(DESTDIR)$(CONFIG_DIR)/htdig.conf;fi
+ @if [ ! -f $(DESTDIR)$(SEARCH_DIR)/mime.types ]; then cp $(top_srcdir)/installdir/mime.types $(DESTDIR)$(SEARCH_DIR)/mime.types; echo $(DESTDIR)$(CONFIG_DIR)/mime.types;fi
+ @if [ ! -f $(DESTDIR)$(SEARCH_DIR)/HtFileType-magic.mime ]; then cp $(top_srcdir)/installdir/HtFileType-magic.mime $(DESTDIR)$(SEARCH_DIR)/HtFileType-magic.mime; echo $(DESTDIR)$(CONFIG_DIR)/HtFileType-magic.mime;fi
$(mkinstalldirs) $(DESTDIR)$(SEARCH_DIR)
@if [ ! -f $(DESTDIR)$(SEARCH_DIR)/$(SEARCH_FORM) ]; then sed -e s%@\IMAGEDIR@%$(IMAGE_URL_PREFIX)% $(top_srcdir)/installdir/search.html >$(DESTDIR)$(SEARCH_DIR)/$(SEARCH_FORM); echo $(DESTDIR)$(SEARCH_DIR)/$(SEARCH_FORM);fi
$(mkinstalldirs) $(DESTDIR)$(COMMON_DIR)
@@ -509,7 +509,7 @@ install-data-local: all
@for i in $(COMMONDICT); do \
if [ ! -f $(DESTDIR)$(COMMON_DIR)/$$i ]; then $(INSTALL_DATA) $(top_srcdir)/installdir/$$i $(DESTDIR)$(COMMON_DIR)/$$i; echo $(DESTDIR)$(COMMON_DIR)/$$i; fi; \
done && test -z "$$fail"
- @if [ ! -f $(DESTDIR)$(CONFIG_DIR)/cookies.txt ]; then cp $(top_srcdir)/installdir/cookies.txt $(DESTDIR)$(CONFIG_DIR)/cookies.txt; echo $(DESTDIR)$(CONFIG_DIR)/cookies.txt;fi
+ @if [ ! -f $(DESTDIR)$(SEARCH_DIR)/cookies.txt ]; then cp $(top_srcdir)/installdir/cookies.txt $(DESTDIR)$(SEARCH_DIR)/cookies.txt; echo $(DESTDIR)$(CONFIG_DIR)/cookies.txt;fi
@echo "Installing images..."
$(mkinstalldirs) $(DESTDIR)$(IMAGE_DIR)
@for i in $(IMAGES); do \