eee51a9821
PostgreSQL 11 provides users with improvements to overall performance of the database system, with specific enhancements associated with very large databases and high computational workloads. Further, PostgreSQL 11 makes significant improvements to the table partitioning system, adds support for stored procedures capable of transaction management, improves query parallelism and adds parallelized data definition capabilities, and introduces just-in-time (JIT) compilation for accelerating the execution of expressions in queries.
74 lines
2.1 KiB
Text
74 lines
2.1 KiB
Text
$NetBSD: patch-src_Makefile.shlib,v 1.1 2018/10/23 16:02:51 adam Exp $
|
|
|
|
Use correct linker flags.
|
|
|
|
--- src/Makefile.shlib.orig 2018-10-15 21:12:02.000000000 +0000
|
|
+++ src/Makefile.shlib
|
|
@@ -157,9 +157,6 @@ endif
|
|
|
|
ifeq ($(PORTNAME), freebsd)
|
|
ifdef ELF_SYSTEM
|
|
- ifdef SO_MAJOR_VERSION
|
|
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
|
- endif
|
|
LINK.shared = $(COMPILER) -shared
|
|
ifdef soname
|
|
LINK.shared += -Wl,-x,-soname,$(soname)
|
|
@@ -170,9 +167,6 @@ ifeq ($(PORTNAME), freebsd)
|
|
LINK.shared += -Wl,--version-script=$(exports_file)
|
|
endif
|
|
else
|
|
- ifdef SO_MAJOR_VERSION
|
|
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
|
|
- endif
|
|
LINK.shared = $(LD) -x -Bshareable -Bforcearchive
|
|
endif
|
|
endif
|
|
@@ -193,6 +187,17 @@ ifeq ($(PORTNAME), netbsd)
|
|
endif
|
|
endif
|
|
|
|
+ifeq ($(PORTNAME), dragonfly)
|
|
+ ifdef ELF_SYSTEM
|
|
+ LINK.shared = $(COMPILER) -shared
|
|
+ ifdef soname
|
|
+ LINK.shared += -Wl,-x,-soname,$(soname)
|
|
+ endif
|
|
+ else
|
|
+ LINK.shared = $(LD) -x -Bshareable -Bforcearchive
|
|
+ endif
|
|
+endif
|
|
+
|
|
ifeq ($(PORTNAME), hpux)
|
|
ifdef SO_MAJOR_VERSION
|
|
shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
|
@@ -248,7 +253,7 @@ ifeq ($(PORTNAME), solaris)
|
|
ifeq ($(with_gnu_ld), yes)
|
|
LINK.shared += -Wl,-soname,$(soname)
|
|
else
|
|
- LINK.shared += -h $(soname)
|
|
+ LINK.shared += -Wl,-h,$(soname)
|
|
endif
|
|
endif
|
|
endif
|
|
@@ -459,8 +464,10 @@ ifdef soname
|
|
# we don't install $(shlib) on AIX
|
|
# (see http://archives.postgresql.org/message-id/52EF20B2E3209443BC37736D00C3C1380A6E79FE@EXADV1.host.magwien.gv.at)
|
|
ifneq ($(PORTNAME), aix)
|
|
+ifeq ($(PORTNAME), cygwin)
|
|
+ $(INSTALL_SHLIB) $< '$(DESTDIR)$(bindir)/$(shlib)'
|
|
+else
|
|
$(INSTALL_SHLIB) $< '$(DESTDIR)$(libdir)/$(shlib)'
|
|
-ifneq ($(PORTNAME), cygwin)
|
|
ifneq ($(PORTNAME), win32)
|
|
ifneq ($(shlib), $(shlib_major))
|
|
cd '$(DESTDIR)$(libdir)' && \
|
|
@@ -473,7 +480,7 @@ ifneq ($(shlib), $(shlib_bare))
|
|
$(LN_S) $(shlib) $(shlib_bare)
|
|
endif
|
|
endif # not win32
|
|
-endif # not cygwin
|
|
+endif # cygwin
|
|
endif # not aix
|
|
ifneq (,$(findstring $(PORTNAME),win32 cygwin))
|
|
$(INSTALL_SHLIB) $< '$(DESTDIR)$(bindir)/$(shlib)'
|