8ca3dbd641
Also fix broken DESTDIR support. Fixes the following security issues: MFSA 2009-64 Crashes with evidence of memory corruption (rv:1.9.1.4/ 1.9.0.15) MFSA 2009-63 Upgrade media libraries to fix memory safety bugs MFSA 2009-62 Download filename spoofing with RTL override MFSA 2009-61 Cross-origin data theft through document.getSelection() MFSA 2009-59 Heap buffer overflow in string to number conversion MFSA 2009-57 Chrome privilege escalation in XPCVariant::VariantDataToJS() MFSA 2009-56 Heap buffer overflow in GIF color map parser MFSA 2009-55 Crash in proxy auto-configuration regexp parsing MFSA 2009-54 Crash with recursive web-worker calls MFSA 2009-53 Local downloaded file tampering MFSA 2009-52 Form history vulnerable to stealing
21 lines
755 B
Text
21 lines
755 B
Text
$NetBSD: patch-mf,v 1.2 2009/10/28 11:36:36 tnn Exp $
|
|
|
|
Add DragonFly support.
|
|
Make sure nss libraries have a run path defined.
|
|
|
|
--- security/coreconf/config.mk.orig 2009-10-16 17:14:17.000000000 +0200
|
|
+++ security/coreconf/config.mk
|
|
@@ -63,7 +63,7 @@ endif
|
|
#######################################################################
|
|
|
|
TARGET_OSES = FreeBSD BSD_OS NetBSD OpenUNIX OS2 QNX Darwin BeOS OpenBSD \
|
|
- AIX RISCOS WINNT WIN95 WINCE
|
|
+ AIX RISCOS WINNT WIN95 WINCE DragonFly
|
|
|
|
ifeq (,$(filter-out $(TARGET_OSES),$(OS_TARGET)))
|
|
include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
|
|
@@ -212,3 +212,4 @@ endif
|
|
DEFINES += -DUSE_UTIL_DIRECTLY
|
|
USE_UTIL_DIRECTLY = 1
|
|
|
|
+EXTRA_SHARED_LIBS += -Wl,-R${PREFIX}/lib/${MOZILLA_PKG_NAME}
|