pkgsrc/devel/xulrunner/patches/patch-mp

32 lines
753 B
Text

$NetBSD: patch-mp,v 1.2 2009/09/20 15:30:54 sno Exp $
Use Sun audio on NetBSD and OSS on DragonFlyBSD and FreeBSD.
--- media/libsydneyaudio/src/Makefile.in.orig 2009-08-24 17:52:50.000000000 +0200
+++ media/libsydneyaudio/src/Makefile.in 2009-09-20 16:12:16.000000000 +0200
@@ -71,12 +71,24 @@
OS_LIBS += -framework CoreAudio -framework AudioToolbox -framework AudioUnit -framework Carbon
endif
-ifeq ($(OS_ARCH),SunOS)
+ifneq (,$(filter SunOS NetBSD,$(OS_ARCH)))
CSRCS = \
sydney_audio_sunaudio.c \
$(NULL)
endif
+ifeq ($(OS_ARCH),DragonFly)
+CSRCS = \
+ sydney_audio_oss.c \
+ $(NULL)
+endif
+
+ifeq ($(OS_ARCH),FreeBSD)
+CSRCS = \
+ sydney_audio_oss.c \
+ $(NULL)
+endif
+
ifeq ($(OS_ARCH),WINNT)
OS_LIBS += winmm.lib
endif