322a5c6f15
The runpath issue only affected the x86-64 arch on NetBSD. The spec change was only effective on i386, so relocating the change enables the RUNPATH tag in the gcc libraries on the amd64 platform.
427 lines
15 KiB
Text
427 lines
15 KiB
Text
--- gcc/config/dragonfly.h.orig
|
|
+++ gcc/config/dragonfly.h
|
|
@@ -84,7 +84,7 @@
|
|
} \
|
|
%{static:-Bstatic} \
|
|
} \
|
|
- %{!static:--hash-style=gnu} \
|
|
+ %{!static:--hash-style=gnu -rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
|
|
#undef LINK_SPEC
|
|
--- gcc/config/i386/freebsd.h.orig
|
|
+++ gcc/config/i386/freebsd.h
|
|
@@ -77,6 +77,12 @@
|
|
When the -shared link option is used a final link is not being
|
|
done. */
|
|
|
|
+#if FBSD_MAJOR < 10
|
|
+#define ELF_HASH_STYLE "--hash-style=both "
|
|
+#else
|
|
+#define ELF_HASH_STYLE "--hash-style=gnu "
|
|
+#endif
|
|
+
|
|
#undef LINK_SPEC
|
|
#define LINK_SPEC "\
|
|
%{p:%nconsider using '-pg' instead of '-p' with gprof(1)} \
|
|
@@ -88,6 +94,7 @@
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker %(fbsd_dynamic_linker) } \
|
|
%{static:-Bstatic}} \
|
|
+ %{!static:" ELF_HASH_STYLE "-rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
|
|
/* A C statement to output to the stdio stream FILE an assembler
|
|
--- gcc/config/i386/freebsd64.h.orig
|
|
+++ gcc/config/i386/freebsd64.h
|
|
@@ -41,4 +41,5 @@
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker %(fbsd_dynamic_linker) } \
|
|
%{static:-Bstatic}} \
|
|
+ %{!static:" ELF_HASH_STYLE "-rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
--- /dev/null
|
|
+++ libgcc/config/i386/netbsd-unwind.h
|
|
@@ -0,0 +1,178 @@
|
|
+/* DWARF2 EH unwinding support for NetBSD: AMD x86-64 and x86.
|
|
+ Copyright (C) 2015 Free Software Foundation, Inc.
|
|
+ Contributed by John Marino <gnugcc@marino.st>
|
|
+
|
|
+This file is part of GCC.
|
|
+
|
|
+GCC is free software; you can redistribute it and/or modify
|
|
+it under the terms of the GNU General Public License as published by
|
|
+the Free Software Foundation; either version 3, or (at your option)
|
|
+any later version.
|
|
+
|
|
+GCC is distributed in the hope that it will be useful,
|
|
+but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+GNU General Public License for more details.
|
|
+
|
|
+Under Section 7 of GPL version 3, you are granted additional
|
|
+permissions described in the GCC Runtime Library Exception, version
|
|
+3.1, as published by the Free Software Foundation.
|
|
+
|
|
+You should have received a copy of the GNU General Public License and
|
|
+a copy of the GCC Runtime Library Exception along with this program;
|
|
+see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
|
+<http://www.gnu.org/licenses/>. */
|
|
+
|
|
+/* Do code reading to identify a signal frame, and set the frame
|
|
+ state data appropriately. See unwind-dw2.c for the structs. */
|
|
+
|
|
+#include <sys/ucontext.h>
|
|
+#include <machine/frame.h>
|
|
+
|
|
+#define REG_NAME(reg) sf_uc.uc_mcontext.__gregs[_REG_## reg]
|
|
+
|
|
+#ifdef __x86_64__
|
|
+
|
|
+#define MD_FALLBACK_FRAME_STATE_FOR x86_64_netbsd_fallback_frame_state
|
|
+
|
|
+static _Unwind_Reason_Code
|
|
+x86_64_netbsd_fallback_frame_state
|
|
+(struct _Unwind_Context *context, _Unwind_FrameState *fs)
|
|
+{
|
|
+ /* signal_frame is sigframe_siginfo minus sf_ra handler return address */
|
|
+ struct signal_frame {
|
|
+ siginfo_t sf_si; /* actual saved siginfo */
|
|
+ ucontext_t sf_uc; /* actual saved ucontext */
|
|
+ };
|
|
+ struct signal_frame *sf;
|
|
+ long new_cfa;
|
|
+
|
|
+ /* We are looking for the following signal trampoline pattern. If we don't
|
|
+ find it, we are at the end of the stack and can't unwind.
|
|
+
|
|
+ <__sigtramp_siginfo_2+12>: mov $0xffffffffffffffff,%rdi
|
|
+ <__sigtramp_siginfo_2+19>: mov $0x1,%rax
|
|
+ <__sigtramp_siginfo_2+26>: syscall
|
|
+ */
|
|
+
|
|
+ if ( *(unsigned int *) (context->ra + 12) == 0xffc7c748
|
|
+ && *(unsigned int *) (context->ra + 16) == 0x48ffffff
|
|
+ && *(unsigned int *) (context->ra + 20) == 0x0001c0c7
|
|
+ && *(unsigned int *) (context->ra + 24) == 0x050f0000 )
|
|
+ {
|
|
+ sf = (struct signal_frame *) context->cfa;
|
|
+ new_cfa = sf->REG_NAME(RSP);
|
|
+ fs->regs.cfa_how = CFA_REG_OFFSET;
|
|
+ fs->regs.cfa_reg = 7;
|
|
+ fs->regs.cfa_offset = new_cfa - (long) context->cfa;
|
|
+ }
|
|
+ else
|
|
+ {
|
|
+ return _URC_END_OF_STACK;
|
|
+ }
|
|
+
|
|
+ /* The SVR4 register numbering macros aren't usable in libgcc. */
|
|
+ fs->regs.reg[ 0].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 0].loc.offset = (long)&sf->REG_NAME(RAX) - new_cfa;
|
|
+ fs->regs.reg[ 1].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 1].loc.offset = (long)&sf->REG_NAME(RDX) - new_cfa;
|
|
+ fs->regs.reg[ 2].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 2].loc.offset = (long)&sf->REG_NAME(RCX) - new_cfa;
|
|
+ fs->regs.reg[ 3].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 3].loc.offset = (long)&sf->REG_NAME(RBX) - new_cfa;
|
|
+ fs->regs.reg[ 4].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 4].loc.offset = (long)&sf->REG_NAME(RSI) - new_cfa;
|
|
+ fs->regs.reg[ 5].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 5].loc.offset = (long)&sf->REG_NAME(RDI) - new_cfa;
|
|
+ fs->regs.reg[ 6].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 6].loc.offset = (long)&sf->REG_NAME(RBP) - new_cfa;
|
|
+ fs->regs.reg[ 8].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 8].loc.offset = (long)&sf->REG_NAME(R8) - new_cfa;
|
|
+ fs->regs.reg[ 9].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[ 9].loc.offset = (long)&sf->REG_NAME(R9) - new_cfa;
|
|
+ fs->regs.reg[10].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[10].loc.offset = (long)&sf->REG_NAME(R10) - new_cfa;
|
|
+ fs->regs.reg[11].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[11].loc.offset = (long)&sf->REG_NAME(R11) - new_cfa;
|
|
+ fs->regs.reg[12].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[12].loc.offset = (long)&sf->REG_NAME(R12) - new_cfa;
|
|
+ fs->regs.reg[13].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[13].loc.offset = (long)&sf->REG_NAME(R13) - new_cfa;
|
|
+ fs->regs.reg[14].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[14].loc.offset = (long)&sf->REG_NAME(R14) - new_cfa;
|
|
+ fs->regs.reg[15].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[15].loc.offset = (long)&sf->REG_NAME(R15) - new_cfa;
|
|
+ fs->regs.reg[16].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[16].loc.offset = (long)&sf->REG_NAME(RIP) - new_cfa;
|
|
+ fs->retaddr_column = 16;
|
|
+ fs->signal_frame = 1;
|
|
+ return _URC_NO_REASON;
|
|
+}
|
|
+
|
|
+#else /* Next section is for i386 */
|
|
+
|
|
+#define MD_FALLBACK_FRAME_STATE_FOR x86_netbsd_fallback_frame_state
|
|
+
|
|
+static _Unwind_Reason_Code
|
|
+x86_netbsd_fallback_frame_state
|
|
+(struct _Unwind_Context *context, _Unwind_FrameState *fs)
|
|
+{
|
|
+ /* signal_frame is sigframe_siginfo minus sf_ra handler return address */
|
|
+ struct signal_frame {
|
|
+ int sf_signum; /* "signum" argument for handler" */
|
|
+ siginfo_t *sf_sip; /* "sip" argument for handler" */
|
|
+ ucontext_t *sf_ucp; /* "ucp" argument for handler" */
|
|
+ siginfo_t sf_si; /* actual saved siginfo */
|
|
+ ucontext_t sf_uc; /* actual saved ucontext */
|
|
+ };
|
|
+ struct signal_frame *sf;
|
|
+ long new_cfa;
|
|
+
|
|
+ /* We are looking for the following signal trampoline pattern. If we don't
|
|
+ find it, we are at the end of the stack and can't unwind.
|
|
+
|
|
+ <__sigtramp_siginfo_2+18>: movl $0xffffffff,0x4(%esp)
|
|
+ <__sigtramp_siginfo_2+26>: mov $0x1,%eax
|
|
+ <__sigtramp_siginfo_2+31>: int $0x80
|
|
+ */
|
|
+
|
|
+ if ( *(unsigned int *) (context->ra + 18) == 0x042444c7
|
|
+ && *(unsigned int *) (context->ra + 22) == 0xffffffff
|
|
+ && *(unsigned char *) (context->ra + 26) == 0xb8
|
|
+ && *(unsigned int *) (context->ra + 27) == 0x00000001
|
|
+ && *(unsigned short *) (context->ra + 31) == 0x80cd )
|
|
+ {
|
|
+ sf = (struct signal_frame *) context->cfa;
|
|
+ new_cfa = sf->REG_NAME(ESP);
|
|
+ fs->regs.cfa_how = CFA_REG_OFFSET;
|
|
+ fs->regs.cfa_reg = 4;
|
|
+ fs->regs.cfa_offset = new_cfa - (long) context->cfa;
|
|
+ }
|
|
+ else
|
|
+ {
|
|
+ return _URC_END_OF_STACK;
|
|
+ }
|
|
+
|
|
+ /* The SVR4 register numbering macros aren't usable in libgcc. */
|
|
+ fs->regs.reg[0].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[0].loc.offset = (long)&sf->REG_NAME(EAX) - new_cfa;
|
|
+ fs->regs.reg[3].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[3].loc.offset = (long)&sf->REG_NAME(EBX) - new_cfa;
|
|
+ fs->regs.reg[1].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[1].loc.offset = (long)&sf->REG_NAME(ECX) - new_cfa;
|
|
+ fs->regs.reg[2].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[2].loc.offset = (long)&sf->REG_NAME(EDX) - new_cfa;
|
|
+ fs->regs.reg[6].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[6].loc.offset = (long)&sf->REG_NAME(ESI) - new_cfa;
|
|
+ fs->regs.reg[7].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[7].loc.offset = (long)&sf->REG_NAME(EDI) - new_cfa;
|
|
+ fs->regs.reg[5].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[5].loc.offset = (long)&sf->REG_NAME(EBP) - new_cfa;
|
|
+ fs->regs.reg[8].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[8].loc.offset = (long)&sf->REG_NAME(EIP) - new_cfa;
|
|
+ fs->retaddr_column = 8;
|
|
+ fs->signal_frame = 1;
|
|
+ return _URC_NO_REASON;
|
|
+}
|
|
+
|
|
+#endif /* ifdef __x86_64__ */
|
|
--- libiberty/getpagesize.c.orig
|
|
+++ libiberty/getpagesize.c
|
|
@@ -20,6 +20,7 @@
|
|
|
|
*/
|
|
|
|
+#ifndef __ANDROID__
|
|
#ifndef VMS
|
|
|
|
#include "config.h"
|
|
@@ -88,3 +89,4 @@
|
|
}
|
|
|
|
#endif /* VMS */
|
|
+#endif /* __ANDROID__ */
|
|
--- libiberty/setproctitle.c.orig
|
|
+++ libiberty/setproctitle.c
|
|
@@ -40,9 +40,11 @@
|
|
void
|
|
setproctitle (const char *name ATTRIBUTE_UNUSED, ...)
|
|
{
|
|
+#ifndef __ANDROID__
|
|
#ifdef PR_SET_NAME
|
|
/* On GNU/Linux this sets the top visible "comm", but not
|
|
necessarily the name visible in ps. */
|
|
prctl (PR_SET_NAME, name);
|
|
#endif
|
|
+#endif
|
|
}
|
|
--- gcc/config/netbsd-elf.h.orig
|
|
+++ gcc/config/netbsd-elf.h
|
|
@@ -70,6 +70,7 @@
|
|
#define NETBSD_LINK_SPEC_ELF \
|
|
"%{assert*} %{R*} %{rpath*} \
|
|
%{shared:-shared} \
|
|
+ %{!static:-rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{!shared: \
|
|
-dc -dp \
|
|
%{!nostdlib: \
|
|
@@ -84,3 +85,10 @@
|
|
#ifdef HAVE_LD_AS_NEEDED
|
|
#define USE_LD_AS_NEEDED 1
|
|
#endif
|
|
+
|
|
+/* Define this to be nonzero if static stack checking is supported. */
|
|
+#define STACK_CHECK_STATIC_BUILTIN 1
|
|
+
|
|
+#if defined(HAVE_LD_EH_FRAME_HDR)
|
|
+#define LINK_EH_SPEC "%{!static:--eh-frame-hdr} "
|
|
+#endif
|
|
--- gcc/config.gcc.orig
|
|
+++ gcc/config.gcc
|
|
@@ -1399,12 +1399,16 @@
|
|
tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${fbsd_tm_file} i386/x86-64.h i386/freebsd.h i386/freebsd64.h"
|
|
;;
|
|
i[34567]86-*-netbsdelf*)
|
|
- tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h netbsd.h netbsd-elf.h i386/netbsd-elf.h"
|
|
+ tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h netbsd.h netbsd-elf.h i386/netbsd-elf.h freebsd-stdint.h"
|
|
extra_options="${extra_options} netbsd.opt netbsd-elf.opt"
|
|
+ tmake_file="${tmake_file} i386/t-crtstuff"
|
|
+ use_gcc_stdint=wrap
|
|
;;
|
|
x86_64-*-netbsd*)
|
|
- tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h netbsd.h netbsd-elf.h i386/x86-64.h i386/netbsd64.h"
|
|
+ tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h netbsd.h netbsd-elf.h i386/x86-64.h i386/netbsd64.h freebsd-stdint.h"
|
|
extra_options="${extra_options} netbsd.opt netbsd-elf.opt"
|
|
+ tmake_file="${tmake_file} i386/t-crtstuff"
|
|
+ use_gcc_stdint=wrap
|
|
;;
|
|
i[34567]86-*-openbsd2.*|i[34567]86-*openbsd3.[0123])
|
|
tm_file="i386/i386.h i386/unix.h i386/bsd.h i386/gas.h i386/gstabs.h openbsd-oldgas.h openbsd.h i386/openbsd.h"
|
|
--- gcc/configure.orig
|
|
+++ gcc/configure
|
|
@@ -27961,6 +27961,13 @@
|
|
gcc_cv_target_dl_iterate_phdr=no
|
|
fi
|
|
;;
|
|
+ *-*-netbsd*)
|
|
+ if grep dl_iterate_phdr $target_header_dir/link_elf.h > /dev/null 2>&1; then
|
|
+ gcc_cv_target_dl_iterate_phdr=yes
|
|
+ else
|
|
+ gcc_cv_target_dl_iterate_phdr=no
|
|
+ fi
|
|
+ ;;
|
|
esac
|
|
|
|
if test x$gcc_cv_target_dl_iterate_phdr = xyes; then
|
|
--- libgcc/crtstuff.c.orig
|
|
+++ libgcc/crtstuff.c
|
|
@@ -81,7 +81,7 @@
|
|
#endif
|
|
|
|
#if defined(TARGET_DL_ITERATE_PHDR) && \
|
|
- (defined(__DragonFly__) || defined(__FreeBSD__))
|
|
+ (defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD__))
|
|
#define BSD_DL_ITERATE_PHDR_AVAILABLE
|
|
#endif
|
|
|
|
--- libgcc/unwind-dw2-fde-dip.c.orig
|
|
+++ libgcc/unwind-dw2-fde-dip.c
|
|
@@ -65,6 +65,12 @@
|
|
#endif
|
|
|
|
#if !defined(inhibit_libc) && defined(HAVE_LD_EH_FRAME_HDR) \
|
|
+ && defined(TARGET_DL_ITERATE_PHDR) && defined(__NetBSD__)
|
|
+# define ElfW(type) Elf_##type
|
|
+# define USE_PT_GNU_EH_FRAME
|
|
+#endif
|
|
+
|
|
+#if !defined(inhibit_libc) && defined(HAVE_LD_EH_FRAME_HDR) \
|
|
&& defined(__OpenBSD__)
|
|
# define ElfW(type) Elf_##type
|
|
# define USE_PT_GNU_EH_FRAME
|
|
--- libgcc/config.host.orig
|
|
+++ libgcc/config.host
|
|
@@ -240,7 +240,8 @@
|
|
extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
|
|
;;
|
|
*-*-netbsd*)
|
|
- tmake_file="$tmake_file t-crtstuff-pic t-libgcc-pic t-slibgcc t-slibgcc-gld t-slibgcc-elf-ver"
|
|
+ tmake_file="$tmake_file t-crtstuff-pic t-libgcc-pic t-eh-dw2-dip"
|
|
+ tmake_file="$tmake_file t-slibgcc t-slibgcc-gld t-slibgcc-elf-ver"
|
|
# NetBSD 1.7 and later are set up to use GCC's crtstuff for
|
|
# ELF configurations. We will clear extra_parts in the
|
|
# a.out configurations.
|
|
@@ -579,9 +580,12 @@
|
|
md_unwind_header=i386/freebsd-unwind.h
|
|
;;
|
|
i[34567]86-*-netbsdelf*)
|
|
+ tmake_file="${tmake_file} i386/t-crtstuff"
|
|
+ md_unwind_header=i386/netbsd-unwind.h
|
|
;;
|
|
x86_64-*-netbsd*)
|
|
tmake_file="${tmake_file} i386/t-crtstuff"
|
|
+ md_unwind_header=i386/netbsd-unwind.h
|
|
;;
|
|
i[34567]86-*-openbsd2.*|i[34567]86-*openbsd3.[0123])
|
|
;;
|
|
--- gcc/Makefile.in.orig
|
|
+++ gcc/Makefile.in
|
|
@@ -1163,7 +1163,6 @@
|
|
insn-emit.o \
|
|
insn-extract.o \
|
|
insn-latencytab.o \
|
|
- insn-modes.o \
|
|
insn-opinit.o \
|
|
insn-output.o \
|
|
insn-peep.o \
|
|
@@ -1518,6 +1517,7 @@
|
|
$(OBJS-libcommon-target) @TREEBROWSER@ main.o c-family/cppspec.o \
|
|
$(COLLECT2_OBJS) $(EXTRA_GCC_OBJS) $(GCOV_OBJS) $(GCOV_DUMP_OBJS) \
|
|
$(GCOV_TOOL_OBJS) $(GENGTYPE_OBJS) gcc-ar.o gcc-nm.o gcc-ranlib.o \
|
|
+ insn-modes.o insn-modes-ada.o \
|
|
lto-wrapper.o collect-utils.o
|
|
|
|
# This lists all host object files, whether they are included in this
|
|
@@ -1525,6 +1525,11 @@
|
|
ALL_HOST_OBJS = $(ALL_HOST_FRONTEND_OBJS) $(ALL_HOST_BACKEND_OBJS)
|
|
|
|
BACKEND = libbackend.a main.o @TREEBROWSER@ libcommon-target.a libcommon.a \
|
|
+ insn-modes.o \
|
|
+ $(CPPLIB) $(LIBDECNUMBER)
|
|
+
|
|
+BACKEND2 = libbackend.a main.o @TREEBROWSER@ libcommon-target.a libcommon.a \
|
|
+ insn-modes-ada.o \
|
|
$(CPPLIB) $(LIBDECNUMBER)
|
|
|
|
# This is defined to "yes" if Tree checking is enabled, which roughly means
|
|
@@ -2171,6 +2176,7 @@
|
|
|
|
insn-modes.c: s-modes; @true
|
|
insn-modes.h: s-modes-h; @true
|
|
+insn-modes-ada.c: s-modes-ada; @true
|
|
min-insn-modes.c: s-modes-m; @true
|
|
|
|
s-modes: build/genmodes$(build_exeext)
|
|
@@ -2188,6 +2194,12 @@
|
|
$(SHELL) $(srcdir)/../move-if-change tmp-min-modes.c min-insn-modes.c
|
|
$(STAMP) s-modes-m
|
|
|
|
+s-modes-ada: s-modes
|
|
+ $(shell sed -e 's/: TARGET_96_ROUND_53_LONG_DOUBLE \? &ieee_extended_intel_96_round_53_format //' \
|
|
+ < insn-modes.c > tmp-modes-ada.c)
|
|
+ $(SHELL) $(srcdir)/../move-if-change tmp-modes-ada.c insn-modes-ada.c
|
|
+ $(STAMP) s-modes-ada
|
|
+
|
|
insn-preds.c: s-preds; @true
|
|
tm-preds.h: s-preds-h; @true
|
|
tm-constrs.h: s-constrs-h; @true
|
|
@@ -3333,6 +3345,9 @@
|
|
( cd $(DESTDIR)$(bindir) && \
|
|
$(LN) $(GCC_INSTALL_NAME)$(exeext) $(FULL_DRIVER_NAME) ); \
|
|
fi; \
|
|
+ if [ -f gnat1$(exeext) ] ; then \
|
|
+ ( cd $(DESTDIR)$(bindir) && $(LN) $(GCC_INSTALL_NAME)$(exeext) ada$(exeext) ) \
|
|
+ fi; \
|
|
if [ ! -f gcc-cross$(exeext) ] \
|
|
&& [ "$(GCC_INSTALL_NAME)" != "$(GCC_TARGET_INSTALL_NAME)" ]; then \
|
|
rm -f $(DESTDIR)$(bindir)/$(target_noncanonical)-gcc-tmp$(exeext); \
|
|
--- libgcc/config/i386/t-dragonfly.orig
|
|
+++ libgcc/config/i386/t-dragonfly
|
|
@@ -0,0 +1,2 @@
|
|
+# Required for -fcilkplus support
|
|
+SHLIB_MAPFILES += $(srcdir)/config/i386/libgcc-bsd.ver
|