29984e93ac
This package would fail when a non-privileged user would try to install it. That's because it was trying to create /usr/pkg/var/log directory. Another directory was getting installed into DESTDIR but no further. Added patch: 1) Removes attempt of Makefile to install ${VARBASE}/log 2) ..and directory ${VARBASE}/cache/PackageKit/downloads creation 3) ..which fixes non-root installations The INSTALL file was removed, instead of installing directories in ${VARBASE}, it was installing directories at /. The functionality was replaced with OWN_DIRS+= in the Makefile and verified to work as expected.
15 lines
466 B
Text
15 lines
466 B
Text
$NetBSD: patch-src_Makefile.in,v 1.1 2012/05/22 11:02:50 marino Exp $
|
|
|
|
--- src/Makefile.in.orig 2008-12-09 08:25:54.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -1505,10 +1505,6 @@ org.freedesktop.PackageKit.Transaction.h
|
|
$(srcdir)/org.freedesktop.PackageKit.Transaction.xml
|
|
|
|
install-data-hook:
|
|
- if test -w $(DESTDIR)$(prefix)/; then \
|
|
- mkdir -p $(DESTDIR)$(localstatedir)/cache/PackageKit/downloads; \
|
|
- mkdir -p $(PK_LOG_DIR); \
|
|
- fi
|
|
|
|
clean-local:
|
|
rm -f *~
|