5b4f879e40
* merge changes from http://cr.yp.to/djbdns/doc.tar.gz into: axfr-get.8, tinydns-data.8. * pickdns-conf.8, pickdns-data.8, pickdns.8: remove. * dnscache-conf.8, rbldns-conf.8, tinydns-conf.8, walldns-conf.8: adapt. * axfrdns-conf.8: new. pkgsrc changes: * Convert to bsd.options.mk. Available options: "ignoreip2 inet6". * Set USE_BUILDLINK3=yes. * Patch to honor PKG_SYSCONFDIR. * As long as we're patching, patch the installer to avoid setting unusual permissions on ${PREFIX} and ${PREFIX}/bin. * Work around the standard djbware errno problem on recent Linux glibc. * Update to the latest pkgsrc djbware RESTRICTED clause. * Remove the third-party logfile formatters (they can go elsewhere if needed). * Take maintainership (suggested by zuntum). Bump PKGREVISION.
22 lines
990 B
Text
22 lines
990 B
Text
$NetBSD: patch-aa,v 1.2 2004/09/01 20:07:35 schmonz Exp $
|
|
|
|
--- dnscache-conf.c.orig 2001-02-11 16:11:45.000000000 -0500
|
|
+++ dnscache-conf.c
|
|
@@ -89,13 +89,13 @@ int main(int argc,char **argv)
|
|
if (chdir(auto_home) == -1)
|
|
strerr_die4sys(111,FATAL,"unable to switch to ",auto_home,": ");
|
|
|
|
- fdrootservers = open_read("/etc/dnsroots.local");
|
|
+ fdrootservers = open_read(PKG_SYSCONFDIR"/dnsroots.local");
|
|
if (fdrootservers == -1) {
|
|
if (errno != error_noent)
|
|
- strerr_die2sys(111,FATAL,"unable to open /etc/dnsroots.local: ");
|
|
- fdrootservers = open_read("/etc/dnsroots.global");
|
|
+ strerr_die4sys(111,FATAL,"unable to open ",auto_home,PKG_SYSCONFDIR"/dnsroots.local: ");
|
|
+ fdrootservers = open_read(PKG_SYSCONFDIR"/dnsroots.global");
|
|
if (fdrootservers == -1)
|
|
- strerr_die2sys(111,FATAL,"unable to open /etc/dnsroots.global: ");
|
|
+ strerr_die4sys(111,FATAL,"unable to open ",auto_home,PKG_SYSCONFDIR"/dnsroots.global: ");
|
|
}
|
|
|
|
init(dir,FATAL);
|