* JS 1.6.0 is based on the same branch (1.8.0.9) as Firefox 1.5.0.9 and includes the same stability and security fixes. * JS 1.6.0 includes support for JavaScript 1.6 with support for E4X, several new Array methods, and Array and String generics.
45 lines
1.2 KiB
Text
45 lines
1.2 KiB
Text
$NetBSD: patch-ac,v 1.3 2007/08/12 03:04:33 wiz Exp $
|
|
|
|
--- config/Darwin.mk.orig 2005-02-12 15:10:33.000000000 -0500
|
|
+++ config/Darwin.mk
|
|
@@ -43,13 +43,13 @@
|
|
# Just ripped from Linux config
|
|
#
|
|
|
|
-CC = cc
|
|
+CC = gcc
|
|
CCC = g++
|
|
-CFLAGS += -Wall -Wno-format
|
|
-OS_CFLAGS = -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN
|
|
+CFLAGS += -Wall -Wno-format -no-cpp-precomp -fno-common -pipe
|
|
+OS_CFLAGS = -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN
|
|
|
|
RANLIB = ranlib
|
|
-MKSHLIB = libtool $(XMKSHLIBOPTS) -framework System
|
|
+MKSHLIB = $(CC) -framework System -dynamiclib $(XMKSHLIBOPTS) -lm -lplds4 -lplc4 -lnspr4 $(LDFLAGS)
|
|
|
|
#.c.o:
|
|
# $(CC) -c -MD $*.d $(CFLAGS) $<
|
|
@@ -57,7 +57,6 @@ MKSHLIB = libtool $(XMKSHLIBOPTS) -frame
|
|
CPU_ARCH = $(shell uname -m)
|
|
ifeq (86,$(findstring 86,$(CPU_ARCH)))
|
|
CPU_ARCH = x86
|
|
-OS_CFLAGS+= -DX86_LINUX
|
|
endif
|
|
GFX_ARCH = x
|
|
|
|
@@ -65,14 +64,6 @@ OS_LIBS = -lc -framework System
|
|
|
|
ASFLAGS += -x assembler-with-cpp
|
|
|
|
-ifeq ($(CPU_ARCH),alpha)
|
|
-
|
|
-# Ask the C compiler on alpha linux to let us work with denormalized
|
|
-# double values, which are required by the ECMA spec.
|
|
-
|
|
-OS_CFLAGS += -mieee
|
|
-endif
|
|
-
|
|
# Use the editline library to provide line-editing support.
|
|
JS_EDITLINE = 1
|
|
|