pkgsrc/inputmethod/canna/patches/patch-canuum_configure.in
tsutsui e069d8e6c6 Update canna packages to 3.7pl3.
pkgsrc changes:
 - reorganize patch filenames for maintainability
  - patch-ac is also merged into existing patch-dic_phono_Imakefile
 - fix a missed 64 bit time_t issue in libRK
 - add a hook in cmd.tmpl to disable installation of cmd/forcpp and
   cmd/kpdic in canna-lib
 - tweak SUBDIRS patches in Makefiles to avoid unnecessary builds
   for each packages
 - pull various updates to canuum from the original FreeWnn's uum,
   including posix_openpt(3) support, and disable the default but
   obsolete libspt support
 - reorganize curses(3) ops in canuum per curses(3) documents
 - fix misc compiler warnings
 - take maintainership

Upstream changes:

 All changes are noted in ChangeLog and CHANGES.jp in distfile.
 I won't bother to quote ~1700 line ChangeLogs here,
 because this latest 3.7pl3 was released on 2004/05/20 and
 the previous 3.6pl4 was 2003/09/22.
 Highlight points are:
  - binary dictionary format is changed
  - shlib versions are bumped to 1.2 from 1.1
  - new APIs for wchar
  - experimental 64 bit architecture support
  - IPv6 support

Both server and clients (canuum and mule-1.1) are tested on
NetBSD/i386 7.0, NetBSD/amd64 7.0, and NetBSD/luna68k 7.0.
Also thanks to Nobuyoshi SATO, for his initial patch posted
to tech-pkg-ja@.
2015-10-18 03:58:31 +00:00

49 lines
1.8 KiB
Text

$NetBSD: patch-canuum_configure.in,v 1.1 2015/10/18 03:58:31 tsutsui Exp $
Check openpty(3), posix_openpt(3), and ptsname(3).
--- canuum/configure.in.orig 2003-03-24 04:15:22.000000000 +0000
+++ canuum/configure.in
@@ -378,6 +378,8 @@ AC_CHECK_LIB(socket, connect)
AC_CHECK_LIB(bind, getservbyname)
AC_CHECK_LIB(nsl, gethostbyname)
])dnl not CANNA
+dnl libutil only needed by uum with openpty... (determine later)
+AC_CHECK_LIB(util, openpty, [HAVE_LIBUTIL='have_libutil'])
dnl
dnl Checks for header files.
@@ -390,7 +392,7 @@ AC_CHECK_HEADERS(fcntl.h sgtty.h syslog.
sys/file.h sys/ioctl.h sys/time.h sys/types.h sys/param.h \
malloc.h strings.h memory.h \
curses.h ncurses.h term.h termio.h \
- termcap.h sgtty.h sys/termio.h termios.h
+ termcap.h sgtty.h sys/termio.h termios.h libutil.h util.h
)
dnl If you don't use ansidecl.h, use this (and modify Wnn/jserver/error.c)
dnl AC_CHECK_HEADERS(stdarg.h varargs.h, break)
@@ -508,7 +510,8 @@ dnl AC_FUNC_WAIT3
AC_CHECK_FUNCS(random drand48 fchmod getopt \
gethostname select socket closesocket setsockopt send recv \
FD_SET \
- getdtablesize getrlimit syslog vsyslog setenv snprintf)
+ getdtablesize getrlimit syslog vsyslog setenv snprintf \
+ ptsname posix_openpt openpty)
dnl for bcopy/index -> memcpy/strchr conversion (preparation):
AC_CHECK_FUNCS(bcopy bzero bcmp index rindex \
memcpy memmove memset strchr strrchr)
@@ -520,6 +523,14 @@ AC_CHECK_FUNCS(mkdir vasprintf, ,
[JS_SUPPORTOBJS="${JS_SUPPORTOBJS} ${ac_func}.o"])
AC_SUBST(JS_SUPPORTOBJS)
+dnl
+dnl File Existence
+dnl Checking file at compile time may bring false result when cross-
+dnl compiling. So, one have to check generated config.h and edit it
+dnl if necessary after running configure.
+dnl
+dnl AC_CHECK_FILE(/dev/ptmx, AC_DEFINE(HAVE_DEV_PTMX, 1, [/dev/ptmx found]),)
+AC_CHECK_FILES(/dev/ptmx,,)
dnl
dnl Creating Makefiles.