pkgsrc/textproc/html2text/patches/patch-aa
adam d6739a6978 Changes 1.3.2a:
* Compatible with modern compilers
2005-03-24 08:53:28 +00:00

94 lines
2.2 KiB
Text

$NetBSD: patch-aa,v 1.3 2005/03/24 08:53:29 adam Exp $
--- configure.orig 2004-01-12 15:47:18.000000000 +0000
+++ configure
@@ -19,7 +19,7 @@
# Tue Nov 11 21:30:26 CET 2003
-echo='/bin/echo -e'
+echo="${ECHO}"
rm -rf configure-tmp || exit 1;
mkdir configure-tmp || exit 1;
@@ -30,7 +30,7 @@ makedirs=".";
# $CXX
#
-$echo 'Checking C++ compiler... \c';
+$echo -n 'Checking C++ compiler... ';
cat <<EOF >$tmp_file.C;
#include <iostream>
int main(int, char **) {
@@ -55,7 +55,7 @@ $echo "use \"$CXX\"";
# $SYS_POLL_MISSING
#
-$echo 'Checking <sys/poll.h>... \c';
+$echo -n 'Checking <sys/poll.h>... ';
SYS_POLL_MISSING=unknown;
cat <<EOF >$tmp_file.C;
#ifdef SYS_POLL_MISSING /* { */
@@ -95,7 +95,7 @@ esac;
# $SOCKET_LIBRARIES
#
-$echo 'Checking for socket libraries... \c';
+$echo -n 'Checking for socket libraries... ';
SOCKET_LIBRARIES=unknown;
cat >$tmp_file.C <<EOF;
extern "C" int socket();
@@ -126,7 +126,7 @@ fi;
# $BOOL_DEFINITION
#
-$echo 'Checking "bool"... \c';
+$echo -n 'Checking "bool"... ';
BOOL_DEFINITION=unknown;
cat <<EOF >$tmp_file.C;
#ifdef BOOL_DEFINITION
@@ -163,7 +163,7 @@ esac;
# $EXPLICIT
#
-$echo 'Checking "explicit"... \c';
+$echo -n 'Checking "explicit"... ';
EXPLICIT=unknown;
cat <<EOF >$tmp_file.C;
struct C {
@@ -194,7 +194,7 @@ esac;
# $LIBSTDCXX_INCLUDES, $LIBSTDCXX_LIBS
#
-$echo 'Checking Standard C++ library... \c';
+$echo -n 'Checking Standard C++ library... ';
cat <<EOF >$tmp_file.C;
#include <string>
#include <list>
@@ -222,7 +222,7 @@ fi;
# $AUTO_PTR_BROKEN
#
AUTO_PTR_BROKEN="";
-$echo 'Checking "auto_ptr"... \c';
+$echo -n 'Checking "auto_ptr"... ';
cat <<EOF >$tmp_file.C;
#include <memory>
#include <string>
@@ -254,7 +254,7 @@ fi;
# $MAKEDEPEND_INCLUDES
#
MAKEDEPEND_INCLUDES="";
-$echo 'Checking "makedepend" includes... \c';
+$echo -n 'Checking "makedepend" includes... \c';
echo "#include <iostream>" >$tmp_file.C;
MAKEDEPEND_INCLUDES=`$CXX -E $tmp_file.C 2>/dev/null |
sed -n \
@@ -287,7 +287,7 @@ for i in \
MAKEDEPEND_INCLUDES; \
do cmd="$cmd -e \"s|@$i@|\$$i|g\""; done;
for dir in $makedirs; do
- $echo "Creating \"$dir/Makefile\" from \"$dir/Makefile.in\"... \\c";
+ $echo -n "Creating \"$dir/Makefile\" from \"$dir/Makefile.in\"... ";
cat <<EOF >$dir/Makefile;
#