e05ef3d8ed
This version represent >19 month of development since the version 6.4, and the list of changes is far too big to include here. See http://www.haskell.org/ghc/docs/6.6/html/users_guide/release-6-6.html for the list of user visible changes.
13 lines
667 B
Text
13 lines
667 B
Text
$NetBSD: patch-ab,v 1.8 2007/03/24 17:57:20 kristerw Exp $
|
|
|
|
--- ../ghc-6.4.2/mk/bootstrap.mk.orig 2006-07-29 01:11:13.000000000 +0200
|
|
+++ ../ghc-6.4.2/mk/bootstrap.mk 2006-07-29 01:12:31.000000000 +0200
|
|
@@ -149,7 +149,7 @@
|
|
HC_BOOT_LIBS += -lHSreadline -lHStemplate-haskell -lHSunix -lHSunix_cbits
|
|
endif
|
|
|
|
-HC_BOOT_LIBS += -lHSCabal -lHShaskell98 -lHSbase -lHSbase_cbits -lHSparsec -lHSrts -lgmp -lm $(EXTRA_HC_BOOT_LIBS)
|
|
+HC_BOOT_LIBS += -lHSCabal -lHShaskell98 -lHSbase -lHSbase_cbits -lHSparsec -lHSrts -lgmp -Wl,-R@PREFIX@/lib -L@PREFIX@/lib -lm $(EXTRA_HC_BOOT_LIBS)
|
|
|
|
ifeq "$(GhcLibsWithReadline)" "YES"
|
|
HC_BOOT_LIBS += $(patsubst %, -l%, $(LibsReadline))
|