c90e45a289
Provided in PR 20662 by David Ferlier, modified to use pkgsrc libtool and to add users by myself. Clam AntiVirus is an anti-virus toolkit written from scratch. It is licensed under GNU GPL2 and uses the virus database from OpenAntiVirus, which is an another free anti-virus project. In contrast to OpenAntiVirus (which is written in Java), Clam AntiVirus is written entirely in C and its database is KEPT UP TO DATE. It also detects polymorphic viruses as well.
33 lines
893 B
Text
33 lines
893 B
Text
$NetBSD: patch-aa,v 1.1.1.1 2003/03/26 18:55:17 agc Exp $
|
|
|
|
--- configure.in.orig Thu Nov 21 01:43:16 2002
|
|
+++ configure.in Tue Mar 11 17:48:07 2003
|
|
@@ -137,12 +137,7 @@
|
|
AC_SUBST(DBDIR)
|
|
|
|
# config file
|
|
-cfg_dir=`echo $sysconfdir | grep prefix`
|
|
-if test -n "$cfg_dir"; then
|
|
- cfg_dir="$ac_default_prefix/etc"
|
|
-else
|
|
- cfg_dir="$sysconfdir"
|
|
-fi
|
|
+cfg_dir=$prefix/etc
|
|
|
|
CFGDIR=$cfg_dir
|
|
AC_SUBST(CFGDIR)
|
|
@@ -224,9 +219,13 @@
|
|
AC_DEFINE(C_BSD)
|
|
;;
|
|
netbsd*)
|
|
- AC_MSG_RESULT(NetBSD detected. Disabling thread support.)
|
|
+ AC_MSG_RESULT(NetBSD detected. Adding pth stuff.)
|
|
have_pthreads="no"
|
|
AC_DEFINE(C_BSD)
|
|
+ LIBCLAMAV_LIBS="$LIBCLAMAV_LIBS -L/usr/pkg/lib -lpthread"
|
|
+ AC_DEFINE(CL_THREAD_SAFE)
|
|
+ CLAMD_LIBS="-lpthread -L/usr/pkg/lib"
|
|
+ CFLAGS="$CFLAGS -I/usr/pkg/include"
|
|
;;
|
|
bsd*)
|
|
AC_MSG_RESULT(Unknown BSD detected. Disabling thread support.)
|