pkgsrc/devel/py-radare2/patches/patch-python_Makefile
khorben 97660033ee Import py-radare2 version 0.9.9 from wip
radare2 is an advanced commandline hexadecimal editor
with a set of tools for working with binary files.

This package provides Python bindings for radare2.
2015-11-16 01:31:10 +00:00

27 lines
1.1 KiB
Text

$NetBSD: patch-python_Makefile,v 1.1 2015/11/16 01:31:10 khorben Exp $
- look for headers within pkgsrc
- fix build with valabind
--- python/Makefile.orig 2015-07-08 23:09:59.000000000 +0000
+++ python/Makefile
@@ -7,8 +7,8 @@ include ../rules.mk
tri:
valabind --swig -N Radare -o r_debug.i -m r_debug --vapidir ../../libr/vapi/ r_debug
- swig -python -I/usr/include/libr r_debug.i
- $(CC) r_debug_wrap.c -shared -fPIC -I /usr/include/libr -I /usr/include/python2.6/ -o _r_debug.so -lr_debug -lr_bp -lr_reg -lr_util
+ swig -python -I$(PREFIX)/include/libr r_debug.i
+ $(CC) r_debug_wrap.c -shared -fPIC -I$(PREFIX)/include/libr -I$(PREFIX)/include/python2.6/ -o _r_debug.so -lr_debug -lr_bp -lr_reg -lr_util
mytest:
mkdir -p r2
@@ -17,7 +17,7 @@ mytest:
PYTHONPATH=. python test-r_bin.py
bis:
- valabind-cc --swig -NRadare python r_io -I../../libr/include r_io `pkg-config --libs r_io`
+ valabind-cc --swig -NRadare python r_io -I../../libr/include r_io `pkg-config --libs-only-L --libs-only-l r_io`
mrproper:
a=python`python --version 2>&1 | cut -d ' ' -f 2 | cut -d . -f 1,2`/site-packages ; \