pkgsrc/lang/gcc/patches/patch-cl
jmc 2ce70215a8 Update patch set against a sync of source from gnusrc/dist/toolchain.
Not very many overall changes. Main ones include

1. Support for powerpc, arm32 and vax
2. Makefile.gcc can now be included by anything which depends on gcc versions.
   If the version installed isn't 2.95.3 it'll add itself as a BUILD_DEPENDS.
   (XXX: any of the makefile's in pkgsrc should be checked and change to use
    this)

3. Remove special PLIST.NetBSD-sparc as it's no longer needed
4. Change post-extract loop to pick up any arch files from FILESDIR without
   having to hardcode all the archs
5. Remove arch restrictions as this should work on any arch supported by the
   main source tree as of 03/28/02
6. Add PKGREVISION as this clearly isn't stock 2.95.3 (it doesn't change
   gcc --version so version checks won't care).
2002-03-28 10:11:50 +00:00

13 lines
462 B
Text

$NetBSD: patch-cl,v 1.2 2002/03/28 10:11:55 jmc Exp $
--- ../gcc-2.95.3/libstdc++/Makefile.in.orig 2001/04/23 12:02:01 1.1.1.2
+++ ../gcc-2.95.3/libstdc++/Makefile.in 2001/12/19 21:32:50 1.2
@@ -14,7 +14,7 @@
# along with this library; see the file COPYING. If not, write to the Free
# Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-VERSION = 2.10.0
+VERSION = 2.10.0nb1
INTERFACE = 3
gxx_include_dir=${includedir}/g++