23ea6c6ec0
(Changes that can break existing programs are marked with a "*" ) Language features: - Addition of lazy patterns: "lazy <pat>" matches suspensions whose values, after forcing, match the pattern <pat>. - Introduction of private abbreviation types "type t = private <type-expr>", for abstracting the actual manifest type in type abbreviations. - Subtyping is now allowed between a private abbreviation and its definition, and between a polymorphic method and its monomorphic instance. Compilers: - The file name for a compilation unit should correspond to a valid identifier (Otherwise dynamic linking and other things can fail, and a warning is emitted.) * Revised -output-obj: the output name must now be provided; its extension must be one of .o/.obj, .so/.dll, or .c for the bytecode compiler. The compilers can now produce a shared library (with all the needed -ccopts/-ccobjs options) directly. - -dtypes renamed to -annot, records (in .annot files) which function calls are tail calls. - All compiler error messages now include a file name and location, for better interaction with Emacs' compilation mode. - Optimized compilation of "lazy e" when the argument "e" is already evaluated. - Optimized compilation of equality tests with a variant constant constructor. - The -dllib options recorded in libraries are no longer ignored when -use_runtime or -use_prims is used (unless -no_auto_link is explicitly used). - Check that at most one of -pack, -a, -shared, -c, -output-obj is given on the command line. - Optimized compilation of private types as regular manifest types (e.g. abbreviation to float, float array or record types with only float fields). Native-code compiler: - New port: Mac OS X / Intel in 64-bit mode (configure with -cc "gcc -m64"). - A new option "-shared" to produce a plugin that can be dynamically loaded with the native version of Dynlink. - A new option "-nodynlink" to enable optimizations valid only for code that is never dynlinked (no-op except for AMD64). - More aggressive unboxing of floats and boxed integers. - Can select which assembler and asm options to use at configuration time. Run-time system: - New implementation of the page table describing the heap (two-level array in 32 bits, sparse hashtable in 64 bits), fixes issues with address space randomization on 64-bit OS (PR#4448). - New "generational" API for registering global memory roots with the GC, enables faster scanning of global roots. (The functions are caml_*_generational_global_root in <caml/memory.h>.) - New function "caml_raise_with_args" to raise an exception with several arguments from C. - Changes in implementation of dynamic linking of C code: under Win32, use Alain Frisch's flexdll implementation of the dlopen API; under MacOSX, use dlopen API instead of MacOSX bundle API. - Programs may now choose a first-fit allocation policy instead of the default next-fit. First-fit reduces fragmentation but is slightly slower in some cases. Standard library: - Parsing library: new function "set_trace" to programmatically turn on or off the printing of a trace during parsing. - Printexc library: new functions "print_backtrace" and "get_backtrace" to obtain a stack backtrace of the most recently raised exception. New function "record_backtrace" to turn the exception backtrace mechanism on or off from within a program. - Scanf library: fine-tuning of meta format implementation; fscanf behaviour revisited: only one input buffer is allocated for any given input channel; the %n conversion does not count a lookahead character as read. Other libraries: - Dynlink: on some platforms, the Dynlink library is now available in native code. The boolean Dynlink.is_native allows the program to know whether it has been compiled in bytecode or in native code. - Bigarrays: added "unsafe_get" and "unsafe_set" (non-bound-checking versions of "get" and "set"). - Bigarrays: removed limitation "array dimension < 2^31". - Labltk: added support for TK 8.5. - Num: added conversions between big_int and int32, nativeint, int64. More efficient implementation of Num.quo_num and Num.mod_num. - Threads: improved efficiency of mutex and condition variable operations; improved interaction with Unix.fork (PR#4577). - Unix: added getsockopt_error returning type Unix.error. Added support for TCP_NODELAY and IPV6_ONLY socket options. - Win32 Unix: "select" now supports all kinds of file descriptors. Improved emulation of "lockf" (PR#4609). Tools: - ocamldebug now supported under Windows (MSVC and Mingw ports), but without the replay feature. (Contributed by Dmitry Bely and Sylvain Le Gall at OCamlCore with support from Lexifi.) - ocamldoc: new option -no-module-constraint-filter to include functions hidden by signature constraint in documentation. - ocamlmklib and ocamldep.opt now available under Windows ports. - ocamlmklib no longer supports the -implib option. - ocamlnat: an experimental native toplevel (not built by default). Camlp4: * programs linked with camlp4lib.cma now also need dynlink.cma.
30 lines
1.3 KiB
Text
30 lines
1.3 KiB
Text
$NetBSD: patch-bi,v 1.3 2009/09/07 21:48:14 tonio Exp $
|
|
|
|
--- otherlibs/labltk/support/Makefile.orig 2008-04-22 09:38:07.000000000 +0200
|
|
+++ otherlibs/labltk/support/Makefile 2009-05-21 11:21:02.000000000 +0200
|
|
@@ -25,19 +25,17 @@
|
|
PUB= $(PUBMLI) $(PUBMLI:.mli=.cmi) tkthread.mli tkthread.cmi tkthread.cmo
|
|
|
|
install:
|
|
- if test -d $(INSTALLDIR); then : ; else mkdir $(INSTALLDIR); fi
|
|
- cp $(PUB) lib$(LIBNAME).$(A) $(INSTALLDIR)
|
|
+ if test -d $(INSTALLDIR); then : ; else ${BSD_INSTALL_DATA_DIR} $(INSTALLDIR); fi
|
|
+ ${BSD_INSTALL_DATA} $(PUB) lib$(LIBNAME).$(A) $(INSTALLDIR)
|
|
cd $(INSTALLDIR); $(RANLIB) lib$(LIBNAME).$(A)
|
|
- cd $(INSTALLDIR); chmod 644 $(PUB) lib$(LIBNAME).$(A)
|
|
if test -f dll$(LIBNAME)$(EXT_DLL); then \
|
|
- cp dll$(LIBNAME)$(EXT_DLL) $(STUBLIBDIR)/; fi
|
|
+ ${BSD_INSTALL_DATA} dll$(LIBNAME)$(EXT_DLL) $(STUBLIBDIR)/; fi
|
|
|
|
installopt:
|
|
- @if test -d $(INSTALLDIR); then : ; else mkdir $(INSTALLDIR); fi
|
|
- cp $(PUBMLI:.mli=.cmx) $(INSTALLDIR)
|
|
+ @if test -d $(INSTALLDIR); then : ; else ${BSD_INSTALL_DATA_DIR} $(INSTALLDIR); fi
|
|
+ ${BSD_INSTALL_DATA} $(PUBMLI:.mli=.cmx) $(INSTALLDIR)
|
|
if test -f tkthread.$(O); then \
|
|
- cp tkthread.cmx tkthread.$(O) $(INSTALLDIR); \
|
|
- chmod 644 $(INSTALLDIR)/tkthread.cmx $(INSTALLDIR)/tkthread.$(O); \
|
|
+ ${BSD_INSTALL_DATA} tkthread.cmx tkthread.$(O) $(INSTALLDIR); \
|
|
fi
|
|
|
|
clean:
|