pkgsrc/lang/ocaml/patches/patch-bo
asau 204621bf62 Update to O'Caml 3.12.0, add test target.
Some of the highlights in release 3.12 are:

  * Polymorphic recursion is supported, using explicit type
    declarations on the recursively-defined identifiers.
  * First-class modules: module expressions can be embedded as
    values of the core language, then manipulated like any other
    first-class value, then projected back to the module level.
  * New operator to modify a signature a posteriori: S with type
    t := tau denotes signature S where the t type component is
    removed and substituted by the type tau elsewhere.
  * New notations for record expressions and record patterns:
    { lbl } as shorthand for { lbl = lbl }, and { ...; _ } marks
    record patterns where some labels were intentionally omitted.
  * Local open let open ... in ... now supported by popular demand.
  * Type variables can be bound as type parameters to functions;
    such types are treated like abstract types within the
    function body, and like type variables (possibly generalized)
    outside.
  * The module type of construct enables to recover the module
    type of a given module.
  * Explicit method override using the method! keyword, with
    associated warnings and errors.
2010-08-19 08:06:53 +00:00

32 lines
1.5 KiB
Text

$NetBSD: patch-bo,v 1.3 2010/08/19 08:06:53 asau Exp $
--- otherlibs/systhreads/Makefile.orig 2010-04-27 11:55:08.000000000 +0400
+++ otherlibs/systhreads/Makefile 2010-08-12 14:42:34.000000000 +0400
@@ -70,19 +70,19 @@
rm -f *.o *.a *.so
install:
- if test -f dllthreads.so; then cp dllthreads.so $(STUBLIBDIR)/dllthreads.so; fi
- cp libthreads.a $(LIBDIR)/libthreads.a
+ if test -f dllthreads.so; then $(BSD_INSTALL_DATA) dllthreads.so $(STUBLIBDIR)/dllthreads.so; fi
+ $(BSD_INSTALL_DATA) libthreads.a $(LIBDIR)/libthreads.a
cd $(LIBDIR); $(RANLIB) libthreads.a
- if test -d $(LIBDIR)/threads; then :; else mkdir $(LIBDIR)/threads; fi
- cp $(THREAD_OBJS:.cmo=.cmi) threads.cma $(LIBDIR)/threads
+ if test -d $(LIBDIR)/threads; then :; else $(BSD_INSTALL_DATA_DIR) $(LIBDIR)/threads; fi
+ $(BSD_INSTALL_DATA) $(THREAD_OBJS:.cmo=.cmi) threads.cma $(LIBDIR)/threads
rm -f $(LIBDIR)/threads/stdlib.cma
- cp thread.mli mutex.mli condition.mli event.mli threadUnix.mli $(LIBDIR)
- cp threads.h $(LIBDIR)/caml/threads.h
+ $(BSD_INSTALL_DATA) thread.mli mutex.mli condition.mli event.mli threadUnix.mli $(LIBDIR)
+ $(BSD_INSTALL_DATA) threads.h $(LIBDIR)/caml/threads.h
installopt:
- cp libthreadsnat.a $(LIBDIR)/libthreadsnat.a
+ $(BSD_INSTALL_DATA) libthreadsnat.a $(LIBDIR)/libthreadsnat.a
cd $(LIBDIR); $(RANLIB) libthreadsnat.a
- cp $(THREAD_OBJS:.cmo=.cmx) threads.cmxa threads.a $(LIBDIR)/threads
+ $(BSD_INSTALL_DATA) $(THREAD_OBJS:.cmo=.cmx) threads.cmxa threads.a $(LIBDIR)/threads
cd $(LIBDIR)/threads; $(RANLIB) threads.a
.SUFFIXES: .ml .mli .cmo .cmi .cmx