pkgsrc/net/kdenetwork2/patches/patch-ad
skrll a100f5d455 Update to KDE 2.2.2
Closes pkg/14728 from Mark Davies <mark@mcs.vuw.ac.nz>. Changes from him
with updates from myself.

From www.kde.org... The principal improvements over KDE 2.2.1, release two
months ago, include:

o security-related
	- SSL certificate loading
	- symlink vulnerability in .wmrc access by KDM introduced in 2.2
	- security problem with eFax (used by klprfax)
	- potential problem in PAM invocation by KDM
	- potential harmful side-effect of failed KDM session starts

o new features
	- added support for CodeWeavers' CrossOver plug-in (provides support
	  for QuickTime, etc.)
	- added support for the wheelmouse for scrolling through the
	  KGhostview PS/PDF viewer component
	- ability to search for multiple patterns at a time in the file
	  search dialog
	- debugging multi-threaded applications with KDevelop

o improvements/fixes
	- handling of HTTP links that redirect to FTP
	- POST using SSL through a proxy and sending headers through proxies
	- saving of recently-selected files in the file dialog
	- handling of non-ASCII characters over SMB
	- toolbar button captions with certain styles
	- selecting items with the mouse in Konqueror
	- sorting in Konqueror's textview
	- saving current settings as a theme in the theme manager
	- crashes in KMail with certain mails
	- crash on invoking the KDM chooser
	- non-Latin languages with KDevelop

performance
	- icon loading optimized
	- file dialog speedups
	- stop spinning SMB client processes
	- handling of large files in Kate
2001-12-03 15:37:14 +00:00

22 lines
606 B
Text

$NetBSD: patch-ad,v 1.3 2001/12/03 15:37:18 skrll Exp $
--- kdict/Makefile.in.orig Mon Sep 10 07:17:55 2001
+++ kdict/Makefile.in
@@ -215,8 +215,6 @@
x_includes = @x_includes@
x_libraries = @x_libraries@
-KDE_CXXFLAGS = $(USE_THREADS)
-
# this has all of the subdirectories that make will recurse into. if
# there are none, comment this out
SUBDIRS = applet pics
@@ -226,7 +224,7 @@
bin_PROGRAMS = kdict
# set the include path for X, qt and KDE
-INCLUDES = $(all_includes)
+INCLUDES = $(USE_THREADS) $(all_includes)
# the library search path.
kdict_LDFLAGS = $(KDE_RPATH) $(all_libraries)