years, removing roadblocks to deploying new or ported applications on PostgreSQL. These include: * Synchronous Replication: enable high-availability with consistency across multiple servers * Per-Column Collations: support linguistically-correct sorting per database, table or column. * Unlogged Tables: greatly improves performance for ephemeral data Our community of contributors innovates with cutting-edge features. Version 9.1 includes several which are new to the database industry, such as: * K-Nearest-Neighbor Indexing: index on "distance" for faster location and text search queries * Serializable Snapshot Isolation: keeps concurrent transactions consistent without blocking, using "true serializability" * Writeable Common Table Expressions: execute complex multi-stage data updates in a single query * Security-Enhanced Postgres: deploy military-grade security and Mandatory Access Control
15 lines
553 B
Text
15 lines
553 B
Text
$NetBSD: patch-src_backend_Makefile,v 1.1.1.1 2011/09/15 08:27:39 adam Exp $
|
|
|
|
--- src/backend/Makefile.orig 2010-07-05 18:54:37.000000000 +0000
|
|
+++ src/backend/Makefile
|
|
@@ -17,6 +17,10 @@ subdir = src/backend
|
|
top_builddir = ../..
|
|
include $(top_builddir)/src/Makefile.global
|
|
|
|
+CFLAGS+= $(DL_CFLAGS)
|
|
+LDFLAGS+= $(DL_LDFLAGS)
|
|
+LIBS+= $(DL_LIBS)
|
|
+
|
|
SUBDIRS = access bootstrap catalog parser commands executor foreign lib libpq \
|
|
main nodes optimizer port postmaster regex replication rewrite \
|
|
storage tcop tsearch utils $(top_builddir)/src/timezone
|