4bc7477474
Package changes: - Be a specific/verbose about dependencies' includes and libraries directories - Require Xaw type "standard" - Install complete html documentation - Add libiconv dependency - Remove libgd documentation - Add upcoming libcurl support in comments Changes since version 1.8.10: January 23, 2003 - declare this version 1.9 (3-level version numbering has been dropped now that we have nightly snapshot builds with their own extended numbering.) - general - config.h is no longer installed. config.h is generated by ./configure for the current build only. It may not be applicable for derivative builds. - improve ICONV configure tests - lots of janitor-work to clean up warning messages from -Wall - use @OBJEXT@ in Makefile.am so that .obj is used under cygwin - fixes for Solaris builds - use libpng-config if available - reduce long build times due to touching ast_common.h too often - improve dependency tracking. "make -j8" now works with distcc - autogen.sh fixes to work on RH7.3, RH8.0, and Solaris. - eliminate use of suffix rules which confused some makes. - DOT language allows '+' for concatenation of quoted strings - dot, neato, twopi - fix bugs 209, 210, 214, 216, 217, 222, 224, 225, 229, 230, 233, 236, 237 - update gd into alignment with gd-2.0.9 - change to make libagraph output compatible with libgraph input - add shapes: septagon, pentagon, a_ediamond, rect, rectangle - introduce "ND_...", "ED_...", "GD_...", node/edge/graph-data accessor macros in partial preparation for use of libagraph in dot. - add libdotneato.so, dotneato.h, dotneato-config to aid use of dot libraries by user apps based on installed graphviz-devel rpm and without access to graphviz sources. - new xdot output format providing detailed drawing instructions - new -y command line flag, inverts y coordinates - support multple -T when -o given, as in: cat xxx.dot | dot -Tpng -Tcmap -o xxx which produces xxx.png and xxx.cmap from a single layout computation. Intended for use in CGI programs. - agraph - correct callback ordering for deletions - tools - add gxl2dot and dot2gxl for GXL language conversions - gvui now provides *map output - tcldot, tcldgr, tcldgl - improve tcl8.4 support - extend search path for tcl.h to include /usr/local/include/tcl8.4/ in support of BSD install conventions. - dynagraph - many fixes - change to not build dynagraph by default (use --with-dynagraph) - docs - dotguide updates
30 lines
984 B
Text
30 lines
984 B
Text
$NetBSD: patch-ag,v 1.5 2003/03/03 11:34:59 seb Exp $
|
|
|
|
--- gdtclft/demo/Makefile.in.orig 2003-03-02 20:12:23.000000000 +0000
|
|
+++ gdtclft/demo/Makefile.in
|
|
@@ -206,7 +206,7 @@ install_sh = @install_sh@
|
|
|
|
AUTOMAKE_OPTIONS = 1.4
|
|
|
|
-demodir = $(datadir)/@PACKAGE@/demo
|
|
+demodir = $(prefix)/share/examples/@PACKAGE@
|
|
demo_SCRIPTS = entities
|
|
demo_DATA = entities.README entities.html
|
|
EXTRA_DIST = $(demo_SCRIPTS) $(demo_DATA) CVS/*
|
|
@@ -216,6 +216,7 @@ CONFIG_HEADER = $(top_builddir)/config.h
|
|
CONFIG_CLEAN_FILES =
|
|
SCRIPTS = $(demo_SCRIPTS)
|
|
|
|
+depcomp =
|
|
DIST_SOURCES =
|
|
DATA = $(demo_DATA)
|
|
|
|
@@ -234,7 +235,7 @@ distclean-libtool:
|
|
-rm -f libtool
|
|
$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
|
|
cd $(top_srcdir) && \
|
|
- $(AUTOMAKE) --gnu gdtclft/demo/Makefile
|
|
+ $(AUTOMAKE) --foreign --ignore-deps gdtclft/demo/Makefile
|
|
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
cd $(top_builddir) && \
|
|
CONFIG_HEADERS= CONFIG_LINKS= \
|