c014e9f9f8
Changes since version 1.9: July 9, 2003 - rerelease 1.10 with ast_common.h fix in -devel rpms July 3, 2003 - declare this version 1.10 - general - "mkdir obj;cd obj;../configure;make" now works (bug #293) - "make prefix=xxx" now works (bug #274) - "--with-wish=xxx" now works (bug #270) - remove generated file: ast_common.h from source distributions - make GIF support configurable - added .cvsignore thoughout source tree to reduce CVS noise - FAQ updates - documentation updates for gpr - improve portability of dotneato-config, but requires libtool now - improvements to error processing for library users -gd - sync with gd-2.0.15 - optimize line drawing code - dot, neato, twopi - fix bugs 240,270,274,293,298,303 - support "peripheries=0" without crashing - add support for "dia" output format (-Tdia) - espf fixes (use of showpage) - svg fixes (coordinates and viewBox) - ismap/imap, fixes (quoting of label strings) - fix to "point" shape - improve (m|c|re)alloc usage - improve handling of very-small fonts in bitmap outputs. - various fixes for multiple -T -o feature - add support for splines to records and ports (neato) - various improvements to libpack - dot_init_graph and neato_init_graph external for library users - cluster improvements (neato) - fix support for truecolor - normalize splines so that they now always go from tail to head - add some simple help text for any unrecognized option (e.g. -? -h --help) - tools - extend gpr language to allow access to command-line arguments - add sqrt() function to gpr - add new tool - gvpack - tcldot - use .dll extension if on windows - doted demo - use tcl's file requestor instead of homebrew - add zooming controlled by mousewheel - support additonal export formats
115 lines
5 KiB
Text
115 lines
5 KiB
Text
$NetBSD: patch-au,v 1.6 2003/07/28 10:06:51 seb Exp $
|
|
|
|
--- tclpathplan/Makefile.in.orig 2003-07-27 16:46:59.000000000 +0000
|
|
+++ tclpathplan/Makefile.in
|
|
@@ -224,7 +224,7 @@ libtclplan_la_SOURCES = find_ints.c inte
|
|
libtclplan_la_LIBADD = \
|
|
$(top_builddir)/tclhandle/libtclhandle.la \
|
|
$(top_builddir)/pathplan/libpathplanconvenience.la \
|
|
- $(top_builddir)/tclstubs/libtclstubs.la
|
|
+ ${TCL_STUB_LIB_SPEC}
|
|
|
|
|
|
CLEANFILES = pkgIndex.tcl
|
|
@@ -238,8 +238,7 @@ LTLIBRARIES = $(pkglib_LTLIBRARIES)
|
|
|
|
libtclplan_la_LDFLAGS =
|
|
libtclplan_la_DEPENDENCIES = $(top_builddir)/tclhandle/libtclhandle.la \
|
|
- $(top_builddir)/pathplan/libpathplanconvenience.la \
|
|
- $(top_builddir)/tclstubs/libtclstubs.la
|
|
+ $(top_builddir)/pathplan/libpathplanconvenience.la
|
|
am_libtclplan_la_OBJECTS = find_ints.lo intersect.lo makecw.lo \
|
|
tclpathplan.lo wrapper.lo
|
|
libtclplan_la_OBJECTS = $(am_libtclplan_la_OBJECTS)
|
|
@@ -248,10 +247,7 @@ DEFS = @DEFS@
|
|
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
|
|
CPPFLAGS = @CPPFLAGS@
|
|
LDFLAGS = @LDFLAGS@
|
|
-depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
-@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/find_ints.Plo $(DEPDIR)/intersect.Plo \
|
|
-@AMDEP_TRUE@ $(DEPDIR)/makecw.Plo $(DEPDIR)/tclpathplan.Plo \
|
|
-@AMDEP_TRUE@ $(DEPDIR)/wrapper.Plo
|
|
+depcomp =
|
|
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
|
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
|
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
|
@@ -287,7 +283,7 @@ distclean-libtool:
|
|
-rm -f libtool
|
|
$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
|
|
cd $(top_srcdir) && \
|
|
- $(AUTOMAKE) --gnu tclpathplan/Makefile
|
|
+ $(AUTOMAKE) --foreign --ignore-deps tclpathplan/Makefile
|
|
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
cd $(top_builddir) && \
|
|
CONFIG_HEADERS= CONFIG_LINKS= \
|
|
@@ -320,33 +316,14 @@ mostlyclean-compile:
|
|
distclean-compile:
|
|
-rm -f *.tab.c
|
|
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/find_ints.Plo@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/intersect.Plo@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/makecw.Plo@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/tclpathplan.Plo@am__quote@
|
|
-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/wrapper.Plo@am__quote@
|
|
-
|
|
-distclean-depend:
|
|
- -rm -rf $(DEPDIR)
|
|
-
|
|
.c.o:
|
|
-@AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
$(COMPILE) -c `test -f $< || echo '$(srcdir)/'`$<
|
|
|
|
.c.obj:
|
|
-@AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
$(COMPILE) -c `cygpath -w $<`
|
|
|
|
.c.lo:
|
|
-@AMDEP_TRUE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Plo' tmpdepfile='$(DEPDIR)/$*.TPlo' @AMDEPBACKSLASH@
|
|
-@AMDEP_TRUE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
$(LTCOMPILE) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
|
|
-CCDEPMODE = @CCDEPMODE@
|
|
uninstall-info-am:
|
|
|
|
# This directory's subdirectories are mostly independent; you can cd
|
|
@@ -514,8 +491,8 @@ clean-am: clean-generic clean-libtool cl
|
|
|
|
distclean: distclean-recursive
|
|
|
|
-distclean-am: clean-am distclean-compile distclean-depend \
|
|
- distclean-generic distclean-libtool distclean-tags
|
|
+distclean-am: clean-am distclean-compile distclean-generic \
|
|
+ distclean-libtool distclean-tags
|
|
|
|
dvi: dvi-recursive
|
|
|
|
@@ -550,16 +527,15 @@ uninstall-info: uninstall-info-recursive
|
|
|
|
.PHONY: $(RECURSIVE_TARGETS) GTAGS all all-am all-local check check-am \
|
|
clean clean-generic clean-libtool clean-pkglibLTLIBRARIES \
|
|
- clean-recursive distclean distclean-compile distclean-depend \
|
|
- distclean-generic distclean-libtool distclean-recursive \
|
|
- distclean-tags distdir dvi dvi-am dvi-recursive info info-am \
|
|
- info-recursive install install-am install-data install-data-am \
|
|
- install-data-recursive install-exec install-exec-am \
|
|
- install-exec-recursive install-info install-info-am \
|
|
- install-info-recursive install-man install-pkglibLTLIBRARIES \
|
|
- install-recursive install-strip installcheck installcheck-am \
|
|
- installdirs installdirs-am installdirs-recursive \
|
|
- maintainer-clean maintainer-clean-generic \
|
|
+ clean-recursive distclean distclean-compile distclean-generic \
|
|
+ distclean-libtool distclean-recursive distclean-tags distdir \
|
|
+ dvi dvi-am dvi-recursive info info-am info-recursive install \
|
|
+ install-am install-data install-data-am install-data-recursive \
|
|
+ install-exec install-exec-am install-exec-recursive \
|
|
+ install-info install-info-am install-info-recursive install-man \
|
|
+ install-pkglibLTLIBRARIES install-recursive install-strip \
|
|
+ installcheck installcheck-am installdirs installdirs-am \
|
|
+ installdirs-recursive maintainer-clean maintainer-clean-generic \
|
|
maintainer-clean-recursive mostlyclean mostlyclean-compile \
|
|
mostlyclean-generic mostlyclean-libtool mostlyclean-recursive \
|
|
tags tags-recursive uninstall uninstall-am uninstall-info-am \
|