pkgsrc/devel/gdb6/patches/patch-bk
joerg a5f3be8594 Add DragonFly support. Hack around gettext brokeness. Since it is
easier to patch the output of autoconf, also create gdb/configure
with the changes from configure.in directly, removing the build
dependency on autoconf.
2006-03-14 00:47:50 +00:00

25 lines
674 B
Text

$NetBSD: patch-bk,v 1.1 2006/03/14 00:47:50 joerg Exp $
--- opcodes/configure.orig 2006-03-13 22:59:10.000000000 +0000
+++ opcodes/configure
@@ -3900,9 +3900,12 @@ echo "configure:3900: checking for gette
if eval "test \"`echo '$''{'gt_cv_func_gettext_libintl'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
+ ac_save_LIBS="$LIBS"
+LIBS="-lintl $LIBS"
cat > conftest.$ac_ext <<EOF
#line 3905 "configure"
#include "confdefs.h"
+#include <libintl.h>
int main() {
return (int) gettext ("")
@@ -3918,6 +3921,7 @@ else
gt_cv_func_gettext_libintl=no
fi
rm -f conftest*
+LIBS="$ac_save_LIBS"
fi
echo "$ac_t""$gt_cv_func_gettext_libintl" 1>&6