pkgsrc/x11/fbdesk/patches/patch-aa
obache a71a3ab1d1 Update fbdesk to 1.4.1.
Patch provided by Jason White in PR 38473.

Changes for 1.4.1:
   * Fixed a shape bug which caused it to flicker.
   * Fixed an icon file parsing bug.
Changes for 1.4.0:
   * Imlib2 support:
     FbDesk can now load the following formats:
        xpm, png, jpg, jfi, jfif, pnm, ppm, pgm, pbm, pam,
        tga, gif and bmp.
   * Added new resource:
     fbdesk.textBackground: <color>
   * Added new resource:
     fbdesk.lockPositions: <bool>
     This will lock the position of the icons (also available in the menu)
   * Fixed gcc-4.1 compile problems
     (Thanks Andreas Bierfer andreas.bierfert at lowlatency.de )
Changes for 1.2.2:
   * Fixed --enable/disable-xpm configure option (Thanks Mathias Gumz)
   configure.in
2008-05-10 16:19:16 +00:00

14 lines
380 B
Text

$NetBSD: patch-aa,v 1.2 2008/05/10 16:19:16 obache Exp $
--- src/FbTk/Font.cc.orig 2006-03-25 11:51:33.000000000 +0000
+++ src/FbTk/Font.cc
@@ -180,7 +180,9 @@ bool Font::s_utf8mode = false;
void Font::init() {
// must be set before the first XFontSet is created
+#ifdef HAVE_SETLOCALE
setlocale(LC_CTYPE, "");
+#endif //HAVE_SETLOCALE
}
void Font::shutdown() {