pkgsrc/devel/libslang2/patches/patch-ad
zafer 1cee1ffd3e Update libslang2 to 2.2.2. Add license.
Changelog:

Changes since 2.2.1
1. src/slsmg.c: Call SLutf8_enable if UTF8 mode has not been setup.
2. src/slutty.c:  Allow the hook that gets called when the read
   function gets interrupted to change the read file descriptor.
   Before, if this happened, the SLang_getkey function would return
   SLANG_GETKEY_ERROR.
3. lib/slsh/print.sl: Turn off buffering of the pager pipe.
4. modules/tm/*.tm: A couple of typos corrected (John Houck)
5. src/slmath.c: The round function was not correctly rounding values
   between 0.5 and 1.0.
6. src/slstdio.c,slclass.c: If a call to fwrite produces errno=EPIPE,
   then do not bother trying the write again.
7. modules/fork-module.c:  Use WIFCONTINUED only if it is defined.
8. slsh/Makefile.in: Change the order of the libraries such that the
   newly built ones will be found first.  (Markus Hennecke)
9. src/slagetput.inc: Avoid possible access violation when using a
   range array as an index.
10. doc/tm/rtl/lists.tm: Documented the optional argument to the
    list_to_array function (Manfred Hanke).

Changes since 2.2.0
1. modules/socket-module.c: glibc-2.8 removed the h_addr macro.
2. src/slclass.c: Call clearerr before performing the
   stdio_fread/fwrite functions.
3. src/slstdio.c: typeof in the fputs intrinsic fixed (n instead of dn
   was compared to 0).
4. src/slscanf.c: sscanf will treat NaN and Inf in a case-insensitive
   manner.  Also, the NaN([a-zA-Z0-9]*) form is also supported.
5. src/slang.h: SLclass_set_aelem_init_function was missing from the
   API.
6. src/slmath.c: The expm1 and log1p functions were returning NaN when
   given Inf arguments.
7. src/slmath,c: log1p(-1) produced nan instead of -inf.
8. configure: Added pkg-config support (based upon a debian patch sent
   to me by Luca Bigliardi).
9. doc/tm/rtl/math.tm: Updated the help for set_float_format and added
   documentation for the get_float_format function.
10. autoconf/slangpc.in: Added URL and Libs.private entries to the
    slang.pc pkg-config file.
11. src/slang.h: prototype for SLang_create_array1 missing from slang.h.
12. src/slcurses.c: Added debian patch that adds support for
    additional graphics characters (DIAMOND, DEGREE, etc...).
13. doc/tm/slang.tm: Added a small section about arrays of arrays.
14. src/slang.c: __builtin_expect is used for the stack functions if
    compiled with gcc.
15. src/*.c: A few public variables were not explicitly initialized
    to 0.  Apparantly not doing so causes them not be be exported from
    the windows DLL.

Complete changes at: ftp://space.mit.edu/pub/davis/slang/v2.2/changes.txt
2009-12-16 19:16:58 +00:00

53 lines
2.2 KiB
Text

$NetBSD: patch-ad,v 1.2 2009/12/16 19:16:58 zafer Exp $
--- demo/Makefile.in.orig 2009-12-05 20:03:51.000000000 +0100
+++ demo/Makefile.in
@@ -28,17 +28,17 @@ CONFIG_H = config.h
ALL_CFLAGS = $(CFLAGS) -Dunix -I$(SLANG_INCLUDE)
-COMPILE_CMD = $(CC) -c $(ALL_CFLAGS)
+COMPILE_CMD = $(LIBTOOL) --mode=compile $(CC) -c $(ALL_CFLAGS)
EXECLIBS = -L$(SLANG_LIB) -lslang @M_LIB@ $(TCAPLIB)
-EXECDEPS = $(SLANG_LIB)/libslang.a
+EXECDEPS = $(SLANG_LIB)/libslang.la
DOT_O_DEPS = demolib.c
#---------------------------------------------------------------------------
all: $(CONFIG_H) $(OTHERSTUFF)
-$(CONFIG_H) : $(SLANG_LIB)/libslang.a ../src/config.h
- /bin/cp ../src/config.h $(CONFIG_H)
-$(SLANG_LIB)/libslang.a :
+$(CONFIG_H) : $(SLANG_LIB)/libslang.la ../src/config.h
+ cp ../src/config.h $(CONFIG_H)
+$(SLANG_LIB)/libslang.la :
cd ../src; $(MAKE)
#---------------------------------------------------------------------------
# Housekeeping
@@ -49,21 +49,21 @@ distclean: clean
-/bin/rm -rf Makefile config.h
#
useropen : useropen.o $(useropen_DEPS) $(EXECDEPS)
- $(CC) -o useropen $(LDFLAGS) useropen.o $(useropen_LIBS) $(EXECLIBS)
+ $(LIBTOOL) --mode=link $(CC) -o useropen $(LDFLAGS) useropen.lo $(useropen_LIBS) $(EXECLIBS)
useropen.o : useropen.c $(DOT_O_DEPS) $(useropen_O_DEP)
$(COMPILE_CMD) $(useropen_INC) $(EXECINC) useropen.c
pager : pager.o $(pager_DEPS) $(EXECDEPS)
- $(CC) -o pager $(LDFLAGS) pager.o $(pager_LIBS) $(EXECLIBS)
+ $(LIBTOOL) --mode=link $(CC) -o pager $(LDFLAGS) pager.lo $(pager_LIBS) $(EXECLIBS)
pager.o : pager.c $(DOT_O_DEPS) $(pager_O_DEP)
$(COMPILE_CMD) $(pager_INC) $(EXECINC) pager.c
keypad : keypad.o $(keypad_DEPS) $(EXECDEPS)
- $(CC) -o keypad $(LDFLAGS) keypad.o $(keypad_LIBS) $(EXECLIBS)
+ $(LIBTOOL) --mode=link $(CC) -o keypad $(LDFLAGS) keypad.lo $(keypad_LIBS) $(EXECLIBS)
keypad.o : keypad.c $(DOT_O_DEPS) $(keypad_O_DEP)
$(COMPILE_CMD) $(keypad_INC) $(EXECINC) keypad.c
smgtest : smgtest.o $(smgtest_DEPS) $(EXECDEPS)
- $(CC) -o smgtest $(LDFLAGS) smgtest.o $(smgtest_LIBS) $(EXECLIBS)
+ $(LIBTOOL) --mode=link $(CC) -o smgtest $(LDFLAGS) smgtest.lo $(smgtest_LIBS) $(EXECLIBS)
smgtest.o : smgtest.c $(DOT_O_DEPS) $(smgtest_O_DEP)
$(COMPILE_CMD) $(smgtest_INC) $(EXECINC) smgtest.c