pkgsrc/textproc/diction/patches/patch-aa
reed 20ae37f03c Fix mistake in patch that linked diction to create style!
So style command was actually the diction command.
I guess nobody else used this.
2011-08-05 15:40:47 +00:00

64 lines
2 KiB
Text

$NetBSD: patch-aa,v 1.2 2011/08/05 15:40:47 reed Exp $
--- Makefile.in.orig 2007-08-03 05:05:15.000000000 -0500
+++ Makefile.in 2011-08-05 10:34:05.000000000 -0500
@@ -11,14 +11,14 @@
prefix= @prefix@
exec_prefix= @exec_prefix@
datarootdir= @datarootdir@
-localedir= @localedir@
+localedir= /usr/pkg/share/locale
CC= @CC@
CFLAGS= @CFLAGS@
CPPFLAGS= @CPPFLAGS@ -I. -DSHAREDIR=\"@datarootdir@\" -DLOCALEDIR=\"$(localedir)\"
LDFLAGS= @LDFLAGS@
LIBM= -lm
-LIBS= @LIBS@
+LIBS= @LIBS@ ${LIBPCREPOSIX}
CATALOGS= de.mo en_GB.mo nl.mo
@@ -26,13 +26,13 @@
all-po-no:
all-po-yes: $(CATALOGS)
-diction: diction.o sentence.o misc.o getopt.o getopt1.o
- $(CC) -o $@ $(LDFLAGS) diction.o sentence.o misc.o \
- getopt.o getopt1.o $(LIBS)
-
-style: style.o sentence.o misc.o getopt.o getopt1.o
- $(CC) -o $@ $(LDFLAGS) style.o sentence.o misc.o \
- getopt.o getopt1.o $(LIBM) $(LIBS)
+diction: diction.o sentence.o misc.o
+ ${LIBTOOL} --mode=link --tag=CC $(CC) -o $@ $(LDFLAGS) \
+ diction.lo sentence.lo misc.lo $(LIBS)
+
+style: style.o sentence.o misc.o
+ ${LIBTOOL} --mode=link --tag=CC $(CC) -o $@ $(LDFLAGS) \
+ style.lo sentence.lo misc.lo $(LIBM) $(LIBS)
check: diction
for i in $(srcdir)/test/test*; do $$i || break; done
@@ -61,7 +61,7 @@
done
.c.o:
- $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
+ ${LIBTOOL} --mode=compile --tag=CC $(CC) -c $(CPPFLAGS) $(CFLAGS) -prefer-pic $<
.SUFFIXES: .po .mo
@@ -110,10 +110,8 @@
(b=`pwd`; b=`basename $$b`; cd ..; tar zcvf $$b.tar.gz $$b/COPYING $$b/INSTALL $$b/Makefile.in $$b/README $$b/NEWS $$b/configure $$b/install-sh $$b/de $$b/en $$b/en_GB $$b/nl $$b/test $$b/[a-z]*.*)
#}}}
#{{{ dependencies
-diction.o: diction.c config.h getopt.h misc.h sentence.h
-getopt.o: getopt.c getopt.h getopt_int.h
-getopt1.o: getopt1.c getopt.h getopt_int.h
+diction.o: diction.c config.h misc.h sentence.h
misc.o: misc.c config.h misc.h
sentence.o: sentence.c config.h misc.h sentence.h
-style.o: style.c config.h getopt.h misc.h sentence.h
+style.o: style.c config.h misc.h sentence.h
#}}}